aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorneodarz <neodarz@neodarz.net>2020-08-13 08:09:10 +0200
committerneodarz <neodarz@neodarz.net>2020-08-13 08:09:10 +0200
commit9acb4a5135db19d7086bb93cf5ca64f83f0806cb (patch)
tree13f65419fa2a0c58e3a26d2e281cf6ae654a6181 /CMakeLists.txt
parent1d3775f20177bbe7c1d9afa7c170e78f24f279e4 (diff)
downloadumosapicpp-9acb4a5135db19d7086bb93cf5ca64f83f0806cb.tar.xz
umosapicpp-9acb4a5135db19d7086bb93cf5ca64f83f0806cb.zip
Use an external library for logging
This library has an asynchronous mode who can be useful for speed issues.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b03a34..8cc6265 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,8 +61,11 @@ or
/usr/local/lib")
endif(NOT RESTBED_FOUND)
+if(NOT TARGET spdlog)
+ find_package(spdlog REQUIRED)
+endif()
-add_executable(umosapi main.cpp config.cpp api/umosapi.cpp db/mongo_access.cpp db/uobject.cpp api/umosapi.h config.h db/mongo_access.h db/uobject.h shared.h)
+add_executable(umosapi main.cpp config.cpp api/umosapi.cpp db/mongo_access.cpp db/uobject.cpp api/umosapi.h config.h db/mongo_access.h db/uobject.h shared.h logging.h)
set_property(TARGET umosapi PROPERTY CXX_STANDARD 17)
@@ -77,3 +80,5 @@ target_link_libraries(umosapi PUBLIC ${JSONC_LIBRARIES})
target_include_directories(umosapi PUBLIC ${RESTBED_INCLUDE_DIRS})
target_link_libraries(umosapi PUBLIC ${RESTBED_LIBRARIES})
+
+target_link_libraries(umosapi PUBLIC spdlog::spdlog)