aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorneodarz <neodarz@neodarz.net>2019-08-02 16:11:44 +0200
committerneodarz <neodarz@neodarz.net>2019-08-02 16:11:44 +0200
commit51b01f457351076f24e4a08bdcbfb7e4cf2d045a (patch)
tree473c1a8ff49b52b1e950298053e52c2df43774e8 /CMakeLists.txt
parent185e684a4648849b35cce65a00465cb41a309292 (diff)
downloadumosapicpp-51b01f457351076f24e4a08bdcbfb7e4cf2d045a.tar.xz
umosapicpp-51b01f457351076f24e4a08bdcbfb7e4cf2d045a.zip
Configure mongodb to work correctly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29aa394..8239925 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,9 @@ include_directories(${LIBBSONCXX_INCLUDE_DIR})
find_package(Pistache REQUIRED)
include_directories(${Pistache_INCLUDE_DIR})
+find_package(nlohmann_json REQUIRED)
+include_directories(${JSON_INCLUDE_DIR})
+
#find_package(Boost)
find_package(Threads)
@@ -39,7 +42,8 @@ endif(NOT JSONC_FOUND)
#add_executable(umosapi test.cpp)
-add_executable(umosapi umosapi.cpp)
+
+add_executable(umosapi umosapi.cpp shared.h)
set_property(TARGET umosapi PROPERTY CXX_STANDARD 17)