summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..fd69fd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: neodarz <neodarz@neodarz.net>
+
+pkgbase=terminalimageviewer
+pkgname=terminalimageviewer-git
+_pkgname=TerminalImageViewer
+pkgver=r46.65ebc0a
+pkgrel=1
+pkgdesc="Small C++ program to display images in a (modern) terminal using RGB ANSI codes and unicode block graphics characters"
+arch=('i686' 'x86_64')
+url="https://github.com/stefanhaustein/$_pkgname"
+license=('Apache')
+makedepends=(git)
+provides=("$_pkgname")
+conflicts=("$_pkgname, tiv")
+source=("$pkgname"::"git+https://github.com/stefanhaustein/$_pkgname.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd $srcdir/$pkgname/src/main/cpp
+ make
+}
+
+
+package() {
+ cd $srcdir/$pkgname
+ install -Dm755 src/main/cpp/tiv $pkgdir/usr/bin/tiv
+}
+