aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDmitry Moiseev <m0sia@m0sia.ru>2013-11-07 14:31:34 +0600
committerDmitry Moiseev <m0sia@m0sia.ru>2013-11-07 14:48:58 +0600
commit42d60a9e684b37ea78262b0765347191a40e9f3a (patch)
treed0c76cc03ff60d2aa37ba8a1b9541114e9b68880 /setup.py
parent80b87622e75cd8a7cce0ca6937bcd022c9e8f082 (diff)
downloadpyParrotZikTCP-42d60a9e684b37ea78262b0765347191a40e9f3a.tar.xz
pyParrotZikTCP-42d60a9e684b37ea78262b0765347191a40e9f3a.zip
Added setup.py for py2exe
Diffstat (limited to '')
-rw-r--r--setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..4db493a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,31 @@
+from distutils.core import setup
+import glob
+import py2exe
+
+setup(
+ name = 'parrotziktray',
+ description = 'Parrot Zik Tray',
+ version = '0.1',
+
+ windows = [
+ {
+ 'script': 'ParrotZikTray.py',
+ 'icon_resources': [(1, "./icons/Headphone.ico")],
+ }
+ ],
+
+ options = {
+ 'py2exe': {
+ #'packages':'encodings',
+ # Optionally omit gio, gtk.keysyms, and/or rsvg if you're not using them
+ 'includes': 'cairo, pango, pangocairo, atk, gobject, gio, gtk.keysyms, _winreg',
+ }
+ },
+
+ data_files=[
+ ("icons", glob.glob("icons/*.png"))
+ # If using GTK+'s built in SVG support, uncomment these
+ #os.path.join(gtk_base_path, '..', 'runtime', 'bin', 'gdk-pixbuf-query-loaders.exe'),
+ #os.path.join(gtk_base_path, '..', 'runtime', 'bin', 'libxml2-2.dll'),
+ ]
+) \ No newline at end of file