aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSamuel Smoker <classicsc@users.noreply.github.com>2017-02-26 16:38:37 -0800
committerSamuel Smoker <classicsc@users.noreply.github.com>2017-02-26 16:38:37 -0800
commita8bbe678731f6a6543abf3c405f485a57b6fb788 (patch)
tree57ed8e73109177b3111a30adf0b62e0363055586 /setup.py
downloadsyncthingmanager-a8bbe678731f6a6543abf3c405f485a57b6fb788.tar.xz
syncthingmanager-a8bbe678731f6a6543abf3c405f485a57b6fb788.zip
Initial commit
Diffstat (limited to '')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..15c1074
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+from setuptools import setup, find_packages
+
+setup(
+ name='syncthingmanager',
+ version='0.1.0',
+ description='A commandline tool for controlling the Syncthing API',
+ url ='https://github.com/classicsc/syncthingmanager',
+ author='Samuel Smoker',
+ author_email='smoker@usc.edu',
+ license='GPLv3',
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: End Users/Desktop',
+ 'Intended Audience :: System Administrators',
+ 'Intended Audience :: Developers',
+ 'Topic :: System :: Archiving :: Mirroring',
+ 'Topic :: Utilities',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Programming Language :: Python :: 3.4',
+ ],
+ keywords = 'syncthing',
+ packages = ['syncthingmanager'],
+ install_requires = ['syncthing'],
+ extras_require={
+ 'test': ['pytest']
+ },
+ entry_points={
+ 'console_scripts': [
+ 'stman=syncthingmanager:main',
+ ],
+ },
+)