Subject: [Nel] peer to peer ?

From: <[email-masked]>
Date: Tue, 18 Dec 2001 12:15:59 GMT

--__--__--

Message: 3
From: "Vianney Lecroart" <[email-masked]>
To: <[email-masked]>
Subject: Re: [Nel] server architecture (front end,
load balancing, login service, ....)
Date: Mon, 17 Dec 2001 15:22:30 +0100
charset="iso-8859-1"
Reply-To: [email-masked]

> But how clients are balanced between the N front
ends of a shard ?

For now, the welcome service does a dumb balancement
(try to have the same
player number on each front end).

>>>> Why don't you try to use LVS ?
More generaly do you plan to make direct connection
between client (such peer to peer network, or
distributed computing) ? It could be nice for
reduicing trafic to the server. To havoid cheating,
each client cheeck data as the server does. Maybe it
could be possible to connect people which interract a
lot (in the same area, ...), there is still some
mouvement with server to handle critical ressouces.
So mouvement to the center server are almost reduice
to the minimum.

Does i smoke too much ?

nicO

______________________________________________________________________________
ifrance.com, l'email gratuit le plus complet de l'Internet !
vos emails depuis un navigateur, en POP3, sur Minitel, sur le WAP...
http://www.ifrance.com/_reloc/email.emailif

---

From: "Daniel Miller" <[email-masked]>
Date: Thu, 20 Dec 2001 20:03:29 +0100

There are various reasons why we haven't opted for a peer to peer model.

One of the most basic problems is this:
We are trying to achieve a high level of audio-visual immersion with scenes
in which tens or hundreds of individuals move about fluidly. The majority of
players only have 56k modems and bandwidth is a big issue. The problem with
peer to peer is that each player has to send and receive tens or hundreds of
packets per scene update at a rate of several scene updates per second. The
internet headers alone for these packets are liable to completely drown the
modem.

Internally we use kunning systems to decide which information on which
players is relavent to send to which other players taking bandwidth
constraints into account. This allows us to make optimum use of the
bandwidth available.

This code is tightly tied in with the game systems so I'm affraid it won't
be released for a while yet.

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, December 18, 2001 1:16 PM
To: [email-masked]
Subject: [Nel] peer to peer ?

--__--__--

Message: 3

ends of a shard ?

Does i smoke too much ?

nicO

____________________________________________________________________________
__
ifrance.com, l'email gratuit le plus complet de l'Internet !
vos emails depuis un navigateur, en POP3, sur Minitel, sur le WAP...
http://www.ifrance.com/_reloc/email.emailif

_______________________________________________
Nel mailing list
[email-masked]
/mailman/listinfo.cgi/nel