Subject: [Nel] prb to paint and export patch under 3DSMAX

From: "neuser jean-philippe" <[email-masked]>
Date: Fri, 1 Mar 2002 14:53:25 +0100

hello everybody
i have some problems to make my landscape , specialy to export patch zone

MY CONFIGURATION
Windows XP  Proc AMD XP 1600+  and 256 Mo RAM and ATI Radeon 7200
Visual Studio 6 + SP5
3DSMAX release 3 + character studio 2.2   in c:\3DSMAX

Ok i have compiled snowball demo , plugins max , ligo and tile edit.
Snowball demo and tile_edit works. 

Some files have been installed in c:\3DSMAX_1\plugins by visual studio project 
files are : 
nelconvertpatch.dlm
nelexport.dlu
nelligo.dlx
nelpaintdlm
neltileutility.dlu
i have transfered them into c:\3DSMAX\plugins

i have copied some scripts too

nel_ligo_export.ms and nel_ligoscape.ms into c:\3DSMAX\scripts\utilities
and 
nel_flare.ms , nel_light.ms, nel_material.ms , nel_material.ms.v1,nel_material.ms.v2,
nel_material.ms.v3, nel_material.ms.v5, nel_multi_set.ms, nel_ps.ms, nel_swt.ms, nel_wave_maker.ms 
into c:\3DSMAX\scripts\startup
and
nel_ligoscape.mcr into c:\3DSMAX\scripts\macroScripts

i have copied nel_drv_opengl.dll object_viewer.DLL and object_viewer.cfg into c:\3DSMAX\plugins and c:\3DSMAX

ok now i run 3DSMAX 
i make a quad patch 
i enter 160 in lenght and 160 in width

now i go into modify menu , i select More button and i can i see a nel convert tool in list and i select it.

ok now you say i have to lauch nel tile utility plugin but i m not able able to find anywhere
i only have a tile_edit.exe , so i launch it.
i make a a land , add one tile and add 1 texture ( 128 * 128 in 24 bit and TGA uncompressed format ) 
i save all in c:\temp , set absolute patch and copie image1 in c:\temp

ok now i select More button again, i can see a nel painter tool in list and i select it 
i have a new option in Geometry menu. So i select perspective view  and i select paint.
i see my quad patch in a new windows , with the user_guit.txt , i able to color a little but not to color with my texture ( normal ) 

Ok i do the link between tile_edit and nel_painter ? 

now i exit the painter 
and i run nel_ligoscape script , i understand nothing !! when i select export , nothing export .
There is an other script call nel_ligo_export but if i run it 3DSMAX crach at each time.

ok i need help here !! 

thanks all

---

From: Robert Bjarnason <[email-masked]>
Date: Fri, 1 Mar 2002 14:43:33 -0800

Hi Neuser,

njp> ok now you say i have to lauch nel tile utility plugin but i m not able able to find anywhere
njp> i only have a tile_edit.exe , so i launch it.
njp> i make a a land , add one tile and add 1 texture ( 128 * 128 in 24 bit and TGA uncompressed format ) 
njp> i save all in c:\temp , set absolute patch and copie image1 in c:\temp

njp> Ok i do the link between tile_edit and nel_painter ?

The NeL Tile Bank plugin is in the Utilities section
of the 3D max menus (where the little hammer is).  You
find NeL Tile Bank under NeL Tools if you go into "Configure
Button Sets".  You click on the NeL Tile Bank and then
you click on "Click to choose a bank..." in the
parameters rollout, then you select the Bank you
just created with tile_edit.exe.  Then you can paint
using your textures.

njp> ok i need help here !!

I'm not familiar with LigoScape but to export the
painted zone file you go into the NeL Export in
the Utilities menu's and select Export model
to save you Patch/Zone.  Then you have to weld,
light and create PACS collistion info for your
zones before you can use them in a client application.

Warm regards,
Robert

---

From: Loic Dachary <[email-masked]>
Date: Fri, 1 Mar 2002 17:43:12 +0100

> 3DSMAX release 3 + character studio 2.2   in c:\3DSMAX

	Woudl you be so kind as to send the plugin binaries you have
to "Vianney Lecroart" <[email-masked]> so that he can upload them
in the newly created binary section of nevrax.org ? It will be useful
to other people trying to produce data for nel. My intuition is that
people able to produce nice graphics are not likely to be very amused
to compile the plugin by themselves ;-)

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt