Subject: [Nel] Compilation errors on OpenAL Driver ?!

From: "Yvan POEYMIROU" <[email-masked]>
Date: Tue, 29 Jan 2002 22:41:58 +0100

Hello,

I've tried to build NeL sources on Visual C++ 6.0 SP 5 (I have included all required libraries, and tried with 2 versions of OpenAL : openal-20020127.zip CVS SnapShot or Current CVS Repository).

I took this message :

********************************

--------------------Configuration: driver_openal - Win32 DebugFast--------------------
Compiling...
stdopenal.cpp
E:\Développement\NeL\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
E:\Développement\NeL\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : fatal error C1004: unexpected end of file found
Error executing cl.exe.

nel - 2 error(s), 0 warning(s)

********************************
sound_driver_al.h file seems like that on given line :

********************************
// alGenBuffers, alGenSources
//typedef ALAPI ALvoid ALAPIENTRY (*TGenFunctionAL) ( ALsizei, ALuint* );
typedef ALvoid (*TGenFunctionAL) ( ALsizei, ALuint* );

// alIsBuffer, alIsSource
//typedef ALAPI ALboolean ALAPIENTRY (*TTestFunctionAL) ( ALuint );
typedef ALboolean (*TTestFunctionAL) ( ALuint );

#ifdef EAX_AVAILABLE
// EAXSet global function
extern EAXSet EAXSetProp;     <<<<<<<<<<<<<<<<<<<<< HERE !!!

// EAXGet global function
extern EAXGet EAXGetProp;
#endif

*********************************

Thanks a lot.

Yvan POEYMIROU

---

From: Olivier Cado <[email-masked]>
Date: Wed, 30 Jan 2002 11:55:34 +0100

Hello,
 
> E:\Développement\NeL\code\nel\src\sound\driver\openal\sound_driver_al.h(60)
> : error C2146: syntax error : missing ';' before identifier
> 'EAXSetProp'
> E:\Développement\NeL\code\nel\src\sound\driver\openal\sound_driver_al.h(60)
> : fatal error C1004: unexpected end of file found
> Error executing cl.exe.

Make sure to add the right include paths in your settings.
Under Windows, let's say you have installed OpenAL in the folder C:\OpenAL.
The include paths will be C:\OpenAL\Win and C:\OpenAL\Win\AL
(the paths C:\OpenAL\Include and C:\OpenAL\Include\AL are the wrong ones :-).
This is because the OpenAL platform-dependant implementations have been
developed separately and the header files did not remain the same
(slightly different function names, arguments, defines, and so on).

I hope this will help.

Regards,
Olivier Cado
-- 
      Nevrax   
       Ryzom   http://www.ryzom.com
         NeL