Subject: [Nel] Landscape tools?

From: Róbert Bjarnason <[email-masked]>
Date: Tue, 18 Sep 2001 02:27:09 -0700

Hi,

We have been playing with Snowballs2 and we are
very impressed.  Thank you Nevrax!

Now we are converting our Warp Storm game content
to this version of NeL.  All the 3D Max tools work
fine but I can't figure out how to create the
Retriever bank ".rbank" for our landscape.  In the
documentation for NeL PACS the following is said
under Tools: "Landscape scenery is converted directly
to a surface representation by exported data re-
processing utilities."  Are those utilities
available?

Also, I created a simple in-game landscape painting
tool for the last release of NeL, is anybody working
on something similar?  If not I'll update the painting
tool and release it under the GPL.

Warm regards,
Róbert Bjarnason

InOrbit Entertainment, Inc.

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Mon, 24 Sep 2001 09:42:22 +0200

Hi Róbert,

> very impressed.  Thank you Nevrax!

Thank you  for your coments. Do you know that the NeL landscape 2
si available ? The displacement mapping has been implemented and
the lighter tool has been upgraded (soft shadow + objects shadow +
radiosity-like effect + multiCPU support).
The landscape runs faster now.

The zone lighting process has been modified. We have added a zone dependency
builder that build shadow dependencies from a zone to another. With this
information,
the lighter tool knows what zones cast shadows on the lighted zone.

Shadow from objects are computed this way: when the lighter tool loads a
zone
(ex: a_13.zonew), it loads the instance group with the same name (a_13.ig)
and casts
shadows with its objects. You can add additionnal instance groups too.

> processing utilities."  Are those utilities

The tools that generates those surfaces will be available soon.
For the moment, only one guy at Nevrax can handle it ! :-)

Regards,

Cyril Corvazier
---
Lead 3d programmer
Nevrax France