Subject: [Nel] culling and transforms

From: "[email-masked]"<[email-masked]>
Date: Sat, 30 Jun 2001 12:21:16 +0200

Hi ,
I Just took a look at nevrax code recently and
noticed that rather than transforming AABB when traversing
the scene graph , the choice was made to transform the
view frustum pyramid : it is much more cpu costly :
I didn't check if this choice was relevant : is it really ?

Ho , it dosn't seem to me that nel network code provides
peer2peer networked comm : Am I right ?
Isn't it a nice solution to very large multi-user environments ?

Great job anyway 

Stephane

__________________________________________________
Voila vous propose une boite aux lettres gratuite sur Voila Mail:
http://mail.voila.fr

---

From: "Lionel Berenguier" <[email-masked]>
Date: Mon, 2 Jul 2001 11:14:03 +0200

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, June 30, 2001 12:21 PM
Subject: [Nel] culling and transforms

> view frustum pyramid : it is much more cpu costly :

Is it not nearly the same?

transform the planes:  transform 6 planes => 6*16= 96 muls.
transform the AABB:  transform 8 vectors => 8*12= 96 muls.

But maybe your trick to transform an AABB is to just transform the center
(12), then transform the 3 half vectors of the AABB (3*3 because of their
axis form), and then just do some add ?  (ooops :) )

regards

Lionel.