Subject: [Nel] Compiling Object Viewer w/Release config

From: Robert Bjarnason <[email-masked]>
Date: Mon, 4 Mar 2002 16:01:09 -0800

Hi,

I get the following errors when I try compiling
Object Viewer in Release build mode on Windows,
It works fine in ReleaseDebug mode:

g:\CODE\NEL\SRC\3d/ps_attrib_maker_helper.h(327) : fatal error C1076: compiler limit : internal heap limit reached; use /Zm to specify a higher limit
        g:\CODE\NEL\SRC\3d/ps_attrib_maker_helper.h(939) : see reference to function template instantiation 'void __thiscall NL3D::CPSAttribMakerT<class NLMISC::CRGBA,class NL3D::CPSValueBlendFunc<class NLMISC::CRGBA> >::make4ByIterator(struct NL3D:
:CFDot3AddIterator<struct NL3D::CAdvance1616Iterator<class NLMISC::CVector const *,class NLMISC::CVector> >,void *,unsigned __int32,unsigned __int32,bool) const' being compiled
<...cut...>
g:\CODE\NEL\SRC\3d/ps_attrib_maker_helper.h(467) : fatal error C1076: compiler limit : internal heap limit reached; use /Zm to specify a higher limit
        g:\CODE\NEL\SRC\3d/ps_attrib_maker_helper.h(1032) : see reference to function template instantiation 'void __thiscall NL3D::CPSAttribMakerT<struct NL3D::CPlaneBasis,class NL3D::CPSValueBlendFunc<struct NL3D::CPlaneBasis> >::makeNByIterator(s
truct NL3D::CDecalIterator,void *,unsigned __int32,unsigned __int32,unsigned __int32,bool) const' being compiled

Also when I try re-compiling anything I get
those errors, I always need to use Rebuild
All:

Compiling...
anim_detail_trav.cpp
G:\code\nel\src\3d\anim_detail_trav.cpp(26) : fatal error C1852: '../obj/Release/3d.pch' is not a valid precompiled header file
clip_trav.cpp
<...>

Warm regards,
Robert

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Mon, 4 Mar 2002 17:24:21 +0100

Hi Robert,

> g:\CODE\NEL\SRC\3d/ps_attrib_maker_helper.h(327) : fatal error C1076: compiler limit : internal heap limit reached; use /Zm to
specify a higher limit

Ok, i have passed the /Zm option to 400 in release for object viewer.
Now this option is 400% in release and releasedebug, 500% in debugfast.

> G:\code\nel\src\3d\anim_detail_trav.cpp(26) : fatal error C1852: '../obj/Release/3d.pch' is not a valid precompiled header file

Nel3d now uses precompilated headers to speedup compilation time. It looks like MSVisual have some problems
to handle this correctly. Try to delete all temporary files by hand (../obj/*.*) and rebuild all. Then it should be ok.

Hld.

---

From: Robert Bjarnason <[email-masked]>
Date: Mon, 4 Mar 2002 20:49:38 -0800

Hi Cyril,

Monday, March 04, 2002, 8:24:21 AM, you wrote:
CHC> Ok, i have passed the /Zm option to 400 in release for object viewer.
CHC> Now this option is 400% in release and releasedebug, 500% in debugfast.

I had tried this, but with no luck, I put /Zm500 for Release in
Project->Settings->General->Project Options.  I don't have to
put any /Zm to have the ReleaseDebug compile.  This is super
low priority problem because everything works fine in ReleaseDebug
mode...

>> G:\code\nel\src\3d\anim_detail_trav.cpp(26) : fatal error C1852: '../obj/Release/3d.pch' is not a valid precompiled header file

CHC> Nel3d now uses precompilated headers to speedup compilation time. It looks like MSVisual have some problems
CHC> to handle this correctly. Try to delete all temporary files by hand (../obj/*.*) and rebuild all. Then it should be ok.

I've got no problem rebuilding all, just when I make a
small change in one of my client source files it
gives me those errors and I need to recompile the
3d libraries every time I want to compile the
client.

Those problems are probably some local config
issues with my MSVisual, I'll see if I can fix
it...

Thanks,
Robert

---

From: Robert Bjarnason <[email-masked]>
Date: Tue, 5 Mar 2002 04:51:50 -0800

Hi Cyril,

With your last CVS update where you added
/Zm400 into the object_viewer.dsp file then
everything compiles fine in Release mode...
Maybe the reason it didn't work for me to
add the /Zm400 option to the project was
that I had to save and reload the project
for it to take effect...

Still no luck in getting rid of the C1852 error
when re-compiling stuff. This is no problem for me
I just disabled the precompiled headers for now
in my local configuration.

Thanks,
Robert

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Mon, 4 Mar 2002 17:14:59 +0100

Hi Robert,

Hld.