Subject: [Nel] Linux compiling, ever

From: Vincent Caron <[email-masked]>
Date: Thu, 25 Oct 2001 15:48:28 +0200

src/3d/Makefile.am does not compile these sources :
  animated_morph.cpp
  heat_haze.cpp
  init_3d.cpp
  landscape_def.cpp
  landscape_face_vector_manager.cpp
  landscapeig_manager.cpp
  landscapevb_allocator.cpp
  landscapevb_info.cpp
  mesh_morpher.cpp
  nv_tri_strip_objects.cpp
  nv_vertex_cache.cpp
  particle_system_sound_user.cpp
  quad_effect.cpp
  quad_grid_clip_cluster.cpp
  quad_grid_clip_manager.cpp
  skip_model.cpp
  stripifier.cpp
  tess_face_priority_list.cpp
  vertex_program.cpp
  zone_corner_smoother.cpp
  zone_lighter.cpp

Some are really missing since I can't link snowballs2. I actually checked
the src/3d.dsp for 'SOURCE=', and my list seems complete.

The nvidia stuff does not compile because the code use the ugly 'for (int i=0;
 ....)' variable scoping. Same error here :

quad_grid_clip_manager.cpp:260: name lookup of `i' changed for new ANSI `for' scoping
quad_grid_clip_manager.cpp:254:   using obsolete binding at `i'

We're getting closer ! ;)

---

From: Cedric Valignat <[email-masked]>
Date: Fri, 26 Oct 2001 14:18:55 +0200

Hello Vincent,

Thanks for the bug report, we fix it in our CVS and it will be available
in the public cvs tonigth.

Vincent Caron wrote:
>[...]

Cedric.

---

From: Doug Posner <[email-masked]>
Date: Fri, 26 Oct 2001 17:38:22 +0000

it seems that the configure routine can't find the source files...

[nelns]$ configure  --with-stlport=/home/doug/extracts/STLport-4.0/
configure: error: can not find sources in . or .. 

thanks
doug

---

From: Vincent Caron <[email-masked]>
Date: Sat, 27 Oct 2001 02:48:07 +0200

> configure: error: can not find sources in . or ..

I had to specify also the include path, so try :

configure  --with-stlport=/home/doug/extracts/STLport-4.0/
--with-stlport-include=/home/doug/extracts/STLport-4.0/stlport

---

From: Doug Posner <[email-masked]>
Date: Fri, 26 Oct 2001 18:05:43 +0000

hi vincent-
i tried your fix but i got the same error...
$ ./configure --with-stlport=/home/doug/extracts/STLport-4.0/
--with-stlport-include=/home/doug/extracts/STLport-4.0/stlport
configure: error: can not find sources in . or ..

the error is generated by the following in configure:

# Find the source files, if location was not specified.
if test -z "$srcdir"; then
  ac_srcdir_defaulted=yes
  # Try the directory containing this script, then its parent.
  ac_prog=$0
  ac_confdir=`echo $ac_prog|sed 's%/[^/][^/]*$%%'`
  test "x$ac_confdir" = "x$ac_prog" && ac_confdir=.
  srcdir=$ac_confdir
  if test ! -r $srcdir/$ac_unique_file; then
    srcdir=..
  fi
else
  ac_srcdir_defaulted=no
fi
if test ! -r $srcdir/$ac_unique_file; then
  if test "$ac_srcdir_defaulted" = yes; then
    { echo "configure: error: can not find sources in $ac_confdir or .."
1>&2; exit 1; }
  else
    { echo "configure: error: can not find sources in $srcdir" 1>&2;
exit 1; }
  fi
fi

specifically it's the "$ac_confdir" line that's printing the error.

thanks
doug

Vincent Caron wrote:
> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel

---

From: Cedric Valignat <[email-masked]>
Date: Mon, 29 Oct 2001 15:07:26 +0100

Hi,

> configure: error: can not find sources in . or .. 

That error is comming from the fact that we removed the source code of
the Log service and the Time service in the repository and the
configure.in file was dependent of that code ... that's fixed now.

I'm currently synchronizing the our private CVS and the publi CVS, so
the fixe should be available in few minutes.

Sorry about that ...

Cedric.