Subject: [Nel] Free Software drivers & fps

From: Loic Dachary <[email-masked]>
Date: Thu, 21 Feb 2002 09:44:43 +0100

Hi,

	Yesterday night the player "Thas" was on
itsalive.nevrax.org. He (or she ?-) said to run snowballs on GNU/Linux
with landscape at 12fps on a G400 / PIII733, using the Free Software
drivers provided with XFree-4.2 (not the binary proprietary drivers
you can get gratis on the matrox site).

	I did not have a chance to ask what client.cfg he is using,
the output of glxinfo, if he was displaying the Nel logo or not and I
can't remember if he had snow (although that does not seem to impact
performances). Given that I only have 8fps on a Radeon 7500 / PIII450,
I guess his experience could help me improve the fps on my side.

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt

---

From: "Robert J. Macomber" <[email-masked]>
Date: Thu, 21 Feb 2002 02:24:09 -0700

> you can get gratis on the matrox site).

Yes, that was me.

> 	I did not have a chance to ask what client.cfg he is using,

Straight out of CVS (i.e., 800x600 windowed, no fog, etc.), though I
did do a "/tilenear 0.1" in-game.

> the output of glxinfo,

Appended at the end of this email.

>                        if he was displaying the Nel logo or not

No, I commented it out of the client.

>                                                                 and I
> performances).

I didn't see any snow.  Well, I did, but not the falling sort.

--begin glxinfo output--
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux Systems Inc.
OpenGL renderer string: Mesa DRI G400 20010622 AGP 4x x86/MMX/SSE
OpenGL version string: 1.2 Mesa 3.4.2
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr, 
    GL_EXT_blend_func_separate, GL_EXT_clip_volume_hint, 
    GL_EXT_compiled_vertex_array, GL_EXT_histogram,
GL_EXT_packed_pixels, 
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_stencil_wrap, 
    GL_EXT_texture3D, GL_EXT_texture_env_add, GL_EXT_texture_object, 
    GL_EXT_vertex_array, GL_MESA_window_pos, GL_MESA_resize_buffers, 
    GL_NV_texgen_reflection, GL_PGI_misc_hints, GL_SGIS_pixel_texture, 
    GL_SGIS_texture_edge_clamp
glu version: 1.2 Mesa 3.2
glu extensions:
    GL_EXT_abgr
--end glxinfo output, with the visuals info snipped since it wouldn't
be interesting to someone with a different card--
-- 
Robert Macomber
[email-masked]

---

From: Alain Dutech <[email-masked]>
Date: Thu, 21 Feb 2002 10:40:45 +0100

Hello all,

snowballs compiles fine (thanks to the last patches and contributions), I've downloaded
the data (i.e : snowballs_data_0_2.tar.gz) and installed them but then, at exec time, I get:

[dutech@crevic client]$ snowballs
INF27483 client.cpp 145 : Starting Snowballs !
WRN27483 path.cpp 618 : CPath::insertFileInMap(Root, data/tiles/CVS/Root, 0, ): already inserted from 'data/CVS/Root',
skip it
WRN27483 path.cpp 618 : CPath::insertFileInMap(Repository, data/tiles/CVS/Repository, 0, ): already inserted from
'data/CVS/Repository', skip it
WRN27483 path.cpp 618 : CPath::insertFileInMap(Entries, data/tiles/CVS/Entries, 0, ): already inserted from
'data/CVS/Entries', skip it
WRN27483 path.cpp 618 : CPath::insertFileInMap(Root, data/zones/CVS/Root, 0, ): already inserted from 'data/CVS/Root',
skip it
WRN27483 path.cpp 618 : CPath::insertFileInMap(Repository, data/zones/CVS/Repository, 0, ): already inserted from
'data/CVS/Repository', skip it
WRN27483 path.cpp 618 : CPath::insertFileInMap(Entries, data/zones/CVS/Entries, 0, ): already inserted from
'data/CVS/Entries', skip it
WRN27483 path.cpp 557 : CPath::addSearchPath(data/fonts/n019003l.pfm, 0, ): file 'n019003l.pfm' already inserted in the
map directory (location: data/n019003l.pfm)
WRN27483 path.cpp 557 : CPath::addSearchPath(data/fonts/n019003l.pfb, 0, ): file 'n019003l.pfb' already inserted in the
map directory (location: data/n019003l.pfb)
WRN27483 path.cpp 557 : CPath::addSearchPath(data/fonts/n019003l.afm, 0, ): file 'n019003l.afm' already inserted in the
map directory (location: data/n019003l.afm)
WRN27483 driver_opengl.cpp 785 : Missing Important GL extension: GL_EXT_texture_env_combine => All envcombine are setup
to GL_MODULATE!!!
WRN27483 path.cpp 222 : CPath::lookup(nevrax.tga): file not found
WRN27483 common.cpp 401 : Exception will be launched: Path not found for nevrax.tga
WRN27483 texture_file.cpp 154 : Missing textureFile: nevrax.tga
WRN27483 path.cpp 222 : CPath::lookup(3_AN.ig): file not found
WRN27483 common.cpp 401 : Exception will be launched: Path not found for 3_AN.ig
Abandon

Any hints? I've checked almost everywhere and there's no "nevrax.tga" file nor any "*.ig" ones.
Am I missing an obvious point here?

Alain

---

From: Loic Dachary <[email-masked]>
Date: Thu, 21 Feb 2002 14:18:45 +0100

> did do a "/tilenear 0.1" in-game.

	I'll have to try that. I changed the value in client.cfg but did
not try to do it in game.

 > No, I commented it out of the client.

	I'll have to see how many fps that wins.

 > I didn't see any snow.  Well, I did, but not the falling sort.

	Anyway it does not seem to make a big difference.

 > --begin glxinfo output--

	I guess that AGP 1x (that's me) against AGP 4x (that's you) +
a CPU that is twice as fast as mine counts for something. 

	Thanks for all these informations, it's good to see other
people strugling with fps with Free Software ;-)

	Cheers,

---

From: Loic Dachary <[email-masked]>
Date: Thu, 21 Feb 2002 17:52:47 +0100

> the data (i.e : snowballs_data_0_2.tar.gz) and installed them but then, at exec time, I get:

	Try to get the latest data from /download/cvs/

	The /download/ page should be updated
accordingly, IMHO.

	Cheers,

---

From: "Vianney Lecroart" <[email-masked]>
Date: Thu, 21 Feb 2002 18:33:29 +0100

Hi,

We fix the download page, now, the page  /download/cvs
is out of date and removed!

All NeL, Snowballs and other nevrax.org related datas are here:
/download/

For Snowballs data, erase the data directories before depacking new datas

Regards,

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: Alain Dutech <[email-masked]>
Date: Fri, 22 Feb 2002 08:59:30 +0100

Thanks, it is better (but not quite running) with the new data.

Alain