Subject: [Nel] Okay, I'm getting this now...

From: "Jared Mark" <[email-masked]>
Date: Sun, 18 Feb 2001 05:24:55 -0600

I completely ignored the makefile stuff for stlport, and freetype... 

I think I got it now, except, I'm a little confused about freetype.  I do the freetype make, and it creates a .lib just fine, but it's not named "freetype.lib"... it's named "freetype200b8MT.lib".  at one point it created "freetype200b8.lib" also.

I have gotten the NeL core to compile, and the services .exe files to compile (they all run, but do nothing for me yet...)  I have all of the client projects compiling except one... (my last hurdle perhaps?).

Client Files Project was not compiling because it said it needed "freetype.lib".  Fine... I tried renaming the freetype200b8.lib file to freetype.lib.  Didn't work.  So I tried the other one (the multithreaded one), and it didn't work either.

Here's what it's telling me...

--------------------Configuration: client - Win32 ReleaseDebug--------------------
Linking...
LINK : warning LNK4098: defaultlib "LIBCMT" conflicts with use of other libs; use /NODEFAULTLIB:library
freetype.lib(ftinit.obj) : error LNK2001: unresolved external symbol _psaux_module_class
MSVCRT.lib(crtexe.obj) : error LNK2001: unresolved external symbol _main
ReleaseDebug/snowballs.exe : fatal error LNK1120: 2 unresolved externals
Error executing link.exe.

snowballs.exe - 3 error(s), 1 warning(s)

So, I know my freetype.lib isn't right... so I must not be doing something right with freetype during the making of it.

So I go back to freetype and check it out... well, I had had some problems with the other parts of freetype compiling, but I figured since I had the .lib file i didn't need to bother with the 3 other project files for freetype... here's what they're telling me.

Build : warning : failed to (or don't know how to) build 'C:\My Documents\MyProjects\snowball\freetype\demos\src\ftdump.c'
Compiling...
common.c
fatal error C1083: Cannot open source file: 'C:\My Documents\MyProjects\snowball\freetype\demos\src\common.c': No such file or directory
ftdump.c
fatal error C1083: Cannot open source file: 'C:\My Documents\MyProjects\snowball\freetype\demos\src\ftdump.c': No such file or directory
Error executing cl.exe.

ftdump_D.exe - 2 error(s), 1 warning(s)

It's pretty much the same thing for the other two, so y'all get the idea.

It's 5am and I'm going to bed... Maybe tomorrow I'll be able to figure it out on my own like I did my other stupid mistakes... I know I'm missing something, but I'm too braindead right now to know if it's something obvious or not.  If it's not something obvious, could someone help me? :)

---

From: Julien Hognon <[email-masked]>
Date: Sun, 18 Feb 2001 22:34:48 +0100

Hi,
Have you tried to put the psauxmod.c files in your freetype project ?
(look at the post of Jérome Lanquetot : [Nel] some questions about
buildings Nel under win32)

> Jared Mark a écrit :
[...]

-- 
HOGNON Julien   alias   Luke    

home 		: [email-masked]
university	: [email-masked]
work		: [email-masked]

ICQ number : 36110826

---

From: "Jared Mark" <[email-masked]>
Date: Sun, 18 Feb 2001 19:04:08 -0600

Okay, that worked... thanks

----- Original Message -----
From: "Julien Hognon" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, February 18, 2001 3:34 PM
Subject: Re: [Nel] Okay, I'm getting this now...

> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>