Subject: [Nel] Landscape Building problems

From: Róbert Bjarnason <[email-masked]>
Date: Wed, 5 Dec 2001 17:53:42 -0800

Hi,

I'm building our landscape using the build_gamedata tools.
The process seems to work and all the .zonel, .smallbank,
.farbank, .rbank and .gr files are created.

When I run the client with our landscape the far textures
look all strange, the landscape appears and disappears when
I move around using /goto.  I also never see the near textures.

The .rbank files don't seem to be working because I'm never
snapped to ground on our landscape and can't move except
with /goto.

Everything looks fine in the landscape painter.

I am attaching my export and build log along with the
config and property files as a zip archive.

Any hints?

Warm regards,
Róbert Bjarnason
InOrbit Entertainment, Inc.

---

From: "Benjamin Legros" <[email-masked]>
Date: Thu, 6 Dec 2001 12:28:50 +0100

From: "Róbert Bjarnason" <[email-masked]>

> snapped to ground on our landscape and can't move except

According to the log file, it seems that the build process crashes at the
tessellation pass :

[...]
01/12/04 23:01:37 INF 1928 build_surf.cpp 1186 : setup zone tessellation
2306 10_AC
[...]
01/12/04 23:01:37 INF 1928 build_surf.cpp 1447 : Compute landscape
tessellation
01/12/04 23:01:37 INF 1928 build_surf.cpp 1450 :    - load tile bank
01/12/04 23:01:37 WRN 1928 common.cpp 392 : Exception will be launched: Path
not found for warpstorm.smallbank
01/12/04 23:01:37 INF 1928 main.cpp 241 : Total Span : 0
01/12/04 23:01:37 INF 1928 main.cpp 242 : Total SpanList : 0
01/12/04 23:01:37 INF 1928 main.cpp 325 : total computation time: 0 days, 0
hours, 0 minutes and 0 seconds

The builder doesn't find a path to the file 'warpstorm.smallbank'
It should be located somewhere with the tile files...

Benjamin.

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Thu, 6 Dec 2001 10:37:05 +0100

Hi Róbert, nice to see you again on the list :-)

> I move around using /goto.

Perhaps it is the thread loading process that make some times to load new
zones when you use /goto.

> I also never see the near textures.

If you see arraws, it means the bitmap files are not found.
Are you sure tiles are in a path directory of the client ?
Can you check that your client use .dds tiles and not .tga tiles ? ( use
CTileBank::makeAllExtensionDDS () )

> snapped to ground on our landscape and can't move except

I will ask my coworkers for this.

Regards,

Cyril Corvazier