Subject: [Nel] RE: Cannot start server

From: [email-masked]
Date: Wed, 7 Nov 2001 12:14:29 +1100

Hi Vianney,

Thank for that! I have followed the server.dxt documention and have started
"admin_executor_service", "naming_service", "login_service",
"welcome_service"...but when I tried to start "admin_service", I got into
error again, and the logs are:

Log Starting [01/11/07 11:29:24]
01/11/07 11:29:24 INF: Starting Service 'AS' using NeL (Nov  6 2001
15:36:46)
01/11/07 11:29:24 INF: args = 1
01/11/07 11:29:24 INF: argv[0] = 'admin_service'
01/11/07 11:29:24 AST: "localaddr.ipAddress() != "127.0.0.1"" 
01/11/07 11:29:24 pctest/AS WRN: Exception will be launched: variable "Rec"
not found in file "admin_service.cfg"
01/11/07 11:29:24 pctest/AS WRN: Exception will be launched: variable
"StringMsgFormat" not found in file "admin_service.cfg"
01/11/07 11:29:24 pctest/AS WRN: Exception will be launched: variable "SId"
not found in file "admin_service.cfg"
01/11/07 11:29:24 pctest/AS AST: "localaddr.ipAddress() != "127.0.0.1"" 
01/11/07 11:29:24 pctest/AS WRN: Exception will be launched: Trying to
access to the index 1 but the variable "AESHosts" size is 1
.
.
.
admin_service abort

In admin_service.cfg, I have:

---admin_service.cfg---
NSHost = "pctest";
NSPort = "50000";
AESHosts = "pctest";
-----------------------

What should I put for AESHosts?  Do I need to create my own service?

After I have got the server running, I will go for the client on a window
machine.
I did have a go on trying to compile the client on Linux, with gcc2.96x, but
I received a compile error saying that it cannot reference to
"libnel3d.so"...

I read the mailing-archive at 2001-March, it was explained that this problem
causes by inline function with gcc, and someone said they have fixed this
problem.  But I am stilling have the same error.  Could you tell me how to
fix this?

Thanks,

Wilson

> Message: 2
> From: "Vianney Lecoart" <[email-masked]>
> To: <[email-masked]>
> Subject: Re: [Nel] Cannot start server.
> Date: Tue, 6 Nov 2001 10:29:06 +0100
> charset="iso-8859-1"
> Reply-To: [email-masked]
>
> Hi Wilson,
>
> > I have created a ns.cfg and ls.txt
>
> Theses files are totally out of date, you must take a look to these
files
> (sorry, they are in doxygen format and not generated so it s not
really
easy
> to read):
/cvs/cvsweb.cgi/~checkout~/code/nel/doc/net/service
.dxt
> ?rev=1.2&content-type=text/plain
>
> and
>
>
/cvs/cvsweb.cgi/~checkout~/code/nelns/doc/server.dx
t?re
> v=1.2&content-type=text/plain
>
> These files explain how to create a service and how work default
services
> like naming service and so on.
>
> Anyway, naming_service doesn t need config file so it works fine
without.
>
> > 01/11/06 15:38:37 pctest/NS INF: Service ready
>
> This line means that your services is running fine.
>
> > 01/11/06 15:38:42 pctest/NS WRN: Exception will be launched: Socket
error:
> > Connection to pctest:49997 (127.0.0.1) failed (111: Connection
refused)
>
> Each server could have an admin_executor_service running on it and all
> services of this server will connect on it. All services try, evenly,
to
> connect to the AES and if the connection failed, this output will be
> display. It's not an error, just a warning. (look the url for more
> information) Just launch the admin_executor_service and the
naming_service
> will be quiet.
>
> Vianney Lecroart
> ---
> lead network programmer / nevrax.com
> icq#: 6870415
> homepage: http://ace.planet-d.net
> www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+
o?
K-
> w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?
>
>
>
>
> --__--__--
>
> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>
>
> End of Nel Digest_______________________________________________
> Nel mailing list
> [email-masked]
 /mailman/listinfo.cgi/nel

---

From: "Vianney Lecoart" <[email-masked]>
Date: Wed, 7 Nov 2001 10:53:45 +0100

Hi,

> but when I tried to start "admin_service", I got into error again, and the
logs are:

You don't need to launch admin_service to run a shard. Anyway, look the cfg
that are in the code/nelns directories (for example
code/nelns/admin_service/admin_service.cfg)

> 01/11/07 11:29:24 AST: "localaddr.ipAddress() != "127.0.0.1""

This assert means that you don't have network card :/ (is it true?) or
there's something strange with your OS.
Remove the assert in the inet_address.cpp line 407:
    nlassert( localaddr.ipAddress() != "127.0.0.1" );

> access to the index 1 but the variable "AESHosts" size is 1

AESHosts is not a string variable but an array of string, look
code/nelns/admin_service/admin_service.cfg
It contains the alias string "S1" and the ip of the server "localhost" for
example.

> After I have got the server running, I will go for the client on a window

You can test the client with our nevrax server (itsalive.nevrax.org) look my
last mail.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: Cedric Valignat <[email-masked]>
Date: Wed, 7 Nov 2001 17:55:43 +0100

Hello,

I made some bugfix today in the configuration scripts of NeL and
Snowballs 2 that could fix your problem. The fix will be available on
the public CVS tonigth ...

If it didn't fix your problem, send me the gcc error message, please ?
thanks :-)

> problem.  But I am stilling have the same error.  Could you tell me how to

Cedric.