Subject: [Nel] File formats+other stuff

From: robofly <[email-masked]>
Date: Fri, 5 Jan 2001 17:35:04 -0800

Hi,

We're experimenting with NEL, great work :)  We are
developing an MMRPG called "Warp Storm" and subscribe
to the Open Source development model.  Our company
and game is born from an GPL'ed project I've been
leading since 1998 called Bang formerly known as
JavaMOO.  Now we have a funded development effort
going and have offices in San Francisco and Reykjavík,
Iceland.

We are considering assigning few full time programmers
helping expanding the NEL code-base.

I've gathered that there is support for .3ds for objects
and .bmp for textures.  Is this correct?

Is there any animation support?

In what format is the landscape data tiles?

Do you have an example of a config file for the
client?

What glues .3ds object files to the landscape
data?

Warm regards,
Róbert Viðar Bjarnason
[email-masked]

President, InOrbit Entertainment, Inc.
http://www.in-orbit.net/
http://this.is/bang/

---

From: "Cyril Corvazier" <[email-masked]>
Date: Mon, 8 Jan 2001 11:33:31 +0100

Hi, and welcome on the NeL list.

> What glues .3ds object files to the landscape

NeL library supports only .tga file format and .dds (direct draw surface)
for texture compression (DXTC1, 3 and 5).

The NeL's way to load 3d data is the following:
NeL only reads NeL binary files (like .shape, .bank or .zone). No support
for .3ds files will be provided by Nevrax.
The reason is .3ds is an old file format, and many new features simply don't
exist in it. (vertex weigting, multiple UV by
vertex, patches, vertex color ).
It's easy to build and save NeL data. You only have to write a data
converter or an export plugin for your
3d editor linked with NeL. A paper about 'how to deal with NeL data' will
come soon in the NeL documentation.

At Nevrax, we use a set of crude plugins for 3dsmax builded with NeL, but we
can't distribute them for the moment.

> Is there any animation support?

Support for animation is planed for sure. Those features will be implemented
in NeL:

 * Hierarchical animations.
 * Skinning (with T&L support).
 * Morphing (blend shape).
 * IK solver (position constraints only).
 * Animation layers (merge of weighted animations with IK constraints).

> Do you have an example of a config file for the

I let my co-workers respond to this question.

Thanks for your interest in the NeL project.
---
Cyril Corvazier
Lead 3d programmer
Nevrax France

---

From: "Vianney Lecroart" <[email-masked]>
Date: Mon, 8 Jan 2001 11:48:32 +0100

Hello,

I m one of those co-workers and I'll answer your last question :)

> Do you have an example of a config file for the

yes we have example of config file.
in the generated doc, here:
/docs/doxygen/nel/class_NLMISC__CConfigFile.html
you ll find an example of config file and a sample of code that use it.

we already use the config file in the client, look client.cpp and search
CConfigFile ;-)

it's really quite easy to use, not very flexible but the reason is that we
use lex&yacc so
we can't do all we wanted (like rewrite config file)

Vianney Lecroart
---
lead programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geek.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: "Vianney Lecroart" <[email-masked]>
Date: Mon, 8 Jan 2001 12:15:48 +0100

hello again,

Just a question, why do you want the client config file?
The client automatically create the config file if the config file is not
found.
Anyway, you *can't* run the client because game data are not available for
now.
(you should wait few weeks ;-)

vianney

---

From: robofly <[email-masked]>
Date: Mon, 8 Jan 2001 11:16:45 -0800

Hi Vianney,

Monday, January 08, 2001, 3:15:48 AM, you wrote:
VL> Just a question, why do you want the client config file?
VL> The client automatically create the config file if the config file is not
VL> found.

I just wanted it to see what initial configuration
elements you were using.  I wanted this to gain
better understanding of the NeL platform.  I had already
taken a look at the link you sent me earlier and
it does not reveal anything about the actual content
of the config file.

VL> Anyway, you *can't* run the client because game data are not available for
VL> now.
VL> (you should wait few weeks ;-)

Why did you decide to release NeL as an Open Source
project on the Internet if there is no way to
run it once compiled?

We have a lot of game assets ready that we would
love to test out in the NeL engine.  We use mostly
Maya for our content but we have a couple of 3D Max
licences as well.  Our content currently includes;
textured characters with animations, buildings,
props, height maps and landscape textures.

Warm regard,
Róbert Viðar Bjarnason
[email-masked]

---

From: robofly <[email-masked]>
Date: Mon, 8 Jan 2001 11:22:56 -0800

Hi Cyril,

Thanks for the info :)

Monday, January 08, 2001, 2:33:31 AM, you wrote:
CC> At Nevrax, we use a set of crude plugins for 3dsmax builded with NeL, but we
CC> can't distribute them for the moment.

Are those plugins going to be Open Source? If not, is there
any change of buying them of you, even if they are in a
crude stage?

Warm regards,
Róbert

---

From: "Vianney Lecroart" <[email-masked]>
Date: Tue, 9 Jan 2001 18:22:42 +0100

Hello Robert,

> it does not reveal anything about the actual content

okay, next is the content of our current config file, hope it s what you
wanted:
---- start of client.cfg
// CLIENT CONFIG FILE

FullScreen = 1;    // 1 = yes
Width = 800;
Height = 600;
Depth = 32;
Position = { 819.269836, -738.062500, 8.277040 };    // the last position on
the world (just for prototype)
Heading = { 0.882310, -0.470668, 0.0 };    // the last direction of the head
Background = { 100, 100, 255 }; // color of the background (temporary, we
wait the sky ;)
DataPath = "\\server\gamedata\data/;    // path of where the data are
FontPath = "\\server\code\fonts\arialuni.ttf;  // the font used in the
client (will change)
LanguageIndex = 1;
LSHost = "pc38"; // our login service server
Login = "foo"; // my login
Password = "bar";    // ... i know, it s not crypted :(
ShardIP = "192.168.1.38"; // the last selected shard
CharacterIndex = 0; // the player character (between 2 possibilities)
---- end of client.cfg

> project on the Internet if there is no way to

Don't forget that it's a quite young project
and we need time to give some examples and stuff.
We are currently working on a small sample world to give the community
something to kick around and showcase what NeL can do.
We'll release it next week so please be a little patient.
Of course this example will have nothing to do with our final game.
Its main use is to help us to test our library and test our team production
pipelines.

But, as you said below, you could use NeL with your own data: you don't
*have* to wait for us to provide it !

> props, height maps and landscape textures.

Great! The only potential problem could be for exporting datas.
But it would be neat if you wrote an export pluggin for Maya,
and we'd love to have another example of a program using NeL.

Best regards,

Vianney Lecroart
---