Subject: Re: [Nel] mesa3D

From: [email-masked] (Bernard Hugueney)
Date: Thu, 11 Jan 2001 19:53:28 +0100

In-Reply-To: <[email-masked]>; from [email-masked] on Thu, Jan 11, 2001 at 05:18:40PM +0100
* Valignat Cedric <[email-masked]> [010111 19:18]:

> Hello Francois,
>
> FranBmPis PBqSichon wrote:
> > It seems i need recent mesa3d libs to build NeL.
> > What version do i need?
>
> We are using Mesa 3.3 and we didn't test NeL with other versions yet.

I must say that for once, Debian unstable is not up to date.
I've been left behind recently, even with latest (today's!) xlibmesa-dev :-(
Just when I bought those extra 128 Mo that 'd have allowed me to compile Nel
AND move he mouse cursor :-(
And lanch ddd on the servers because they segfaulted on startup here :-(

I've no relevent version number as debian seem to sync them with XFree's:

bubastis:~# dpkg -p xlibmesa-dev |fgrep Version
Version: 4.0.2-1

bubastis:~# dpkg -L xlibmesa-dev |fgrep glext.h
/usr/include/GL/glext.h
but 
bubastis:~# fgrep GL_GLEXT_VERSION `dpkg -L xlibmesa-dev |fgrep glext.h`
#define GL_GLEXT_VERSION 6
which does not plese Nel :-((

Not your fault As I think one ought to be on the bleeding edge when developping
or your behind when releasing...

I hope to catch up soon...

Bernard

---

From: Valignat Cedric <[email-masked]>
Date: Fri, 12 Jan 2001 12:01:36 +0100

Hello Bernard,

> I've been left behind recently, even with latest (today's!) xlibmesa-dev :-(

Ouch !...

> AND move he mouse cursor :-(

How much RAM did you have, before, to run X ? :-P

> And lanch ddd on the servers because they segfaulted on startup here :-(

Did you get any error messages ?

The servers are, actually, made in a way that they print an error message and
create a core files if there is a problem, that's help us to debug them ...

> which does not plese Nel :-((

The Mesa's rpm that we used is the 3.3-5 version and it use the version 7
of GL/glext.h. We didn't test it with any other version of mesa yet, but you
could try to download the lastest version of GL/glext.h at
http://oss.sgi.com/projects/ogl-sample/ABI/glext.h and recompile NeL.

An other solution is to remove the GL_GLEXT_VERSION checking in the 
configure.in file and in the src/3d/driver/opengl/driver_opengl_extension.h
file and try to recompile NeL ...

I hope that could help you to fixed your problem ...

Cedric.

---

From: Robert Bjarnason <[email-masked]>
Date: Sat, 13 Jan 2001 20:49:54 -0800

Hi Vianney,

VC> okay, next is the content of our current config file, hope it s what you
VC> wanted:

Thanks :)  I like the way you have the config files
created automaticly, I just hadn't looked in the
right place...

VC> Don't forget that it's a quite young project
VC> and we need time to give some examples and stuff.
VC> We are currently working on a small sample world to give the community
VC> something to kick around and showcase what NeL can do.
VC> We'll release it next week so please be a little patient.
VC> Of course this example will have nothing to do with our final game.
VC> Its main use is to help us to test our library and test our team production
VC> pipelines.

I appolagice for my tone of voice before, I really
appricate your effort and think your doing a great
job.

VC> Great! The only potential problem could be for exporting datas.
VC> But it would be neat if you wrote an export pluggin for Maya,
VC> and we'd love to have another example of a program using NeL.

We've already started to work on a plugin, written in MEL Script,
using info gathered from the source code distribution.
Do you have any formal documents on the different fileformats?

Warm regards,
Robert