Subject: [Nel] last compile difficulty I hope... (driver_opengl)

From: "Kai Schutte" <[email-masked]>
Date: Wed, 12 Dec 2001 12:59:01 -0500

Hi, 

I got the 3d lib to compile. I was using the code\snowballs2\snowballs2.dsw workspace, and maybe that's why it wasn't working. I got 3d lib to compile fine under code\nel\nel.dsw.

Okay, I got one more problem, and it seems to be associated with <GL/glext.h> stuff... 
I downloaded and installed the <GL/glext.h> file from the SGI site.
compiler output:

driver_opengl.cpp
D:\skander\code\nel\src\3d\driver\opengl\driver_opengl_extension.h(142) : error C2146: syntax error : missing ';' before identifier 'glActiveTextureARB'
D:\skander\code\nel\src\3d\driver\opengl\driver_opengl_extension.h(142) : fatal error C1004: unexpected end of file found
(repeated 9 times for the next 9 files)

at line 142 in driver_opengl_extension.h you get: 
extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;

which refers to a <GL/glext.h> entry at line 1620: 
typedef void (APIENTRY * PFNGLACTIVETEXTUREARBPROC) (GLenum texture);

I would suppose that this is some sort of precompile error... I've tried changing little things in the vacinity, but everything I did just generated more compile errors. 

Have you bumped into this problem? 

thanks, 
-Kai

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Wed, 12 Dec 2001 19:18:39 +0100

Hi Kai,

  driver_opengl.cpp

I compile without any kind of problem with the current <GL/glext.h> file available on the SGI site. (GL_GLEXT_VERSION = 7)
Please make sure you have included the good file. If it is not the problem, don't hesitate to post again.

I have the same definition at the same line, and it is the only one.

Regards,

Cyril