Subject: [Nel] STL Port yet again.

From: "Jared Mark" <[email-masked]>
Date: Sun, 26 Aug 2001 21:33:05 -0500

Alrighty, I'm rebuilding everything from scratch here, and am having problems again.

I got freetype, and it compiled perfectly... got 4 libs out of that.  (They have a nifty .dsw file now for us VC++6.0 Win32 folks to use).

I still have Python, never uninstalled it... 

But then I go for the STLport thing, and have nothing but problems.  You'd think I'd be okay with this, since I've done it before.

I read the mailing list archives and couldn't find anything regarding this problem... I read the install file that comes with nel, and the one that comes with stlport... no help there.

Here's what I'm doing.

In a command prompt:

I copy vc6-unicode.mak to "makefile"
I run "nmake clean all"
and I get some errors...

first of all, it says "invalid switch - /s"
then it does the cl.exe command line, and exits with this error:
..\\stlport\cstddef(27) : fatal error C1083: Cannot open include file: '../include/cstddef': No such file or directory
NMAKE : fatal error U1077:  (path to cl.exe) : return code '0x2'
Stop.

I've noticed there IS no "include" directory in the stlport files that came with v4.0... so this has me confused... it's looking for files in an include directory, but there is none... are the STLport makefiles wrong?

Anyway, I'm very confused.

---

From: Cedric Valignat <[email-masked]>
Date: Tue, 28 Aug 2001 18:23:54 +0200

Jared Mark wrote:
> [...]

I found something silmilar on the STLPort site :

   - http://www.stlport.com/dcforum/DCForumID7/629.html

      " Please make sure you ran vcvars.bat so set environment for command-line
        MS tools."

I hope that will helps you ... 

Regards,

Cedric.

---

From: "EagleEye" <[email-masked]>
Date: Tue, 28 Aug 2001 19:53:10 -0500

No such file... not in the STLport distrib, or anywhere on my HD.

----- Original Message -----
From: "Cedric Valignat" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 28, 2001 11:23 AM
Subject: Re: [Nel] STL Port yet again.

> > ..\\stlport\cstddef(27) : fatal error C1083: Cannot open include file:
'../include/cstddef': No such file or directory
> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>

---

From: "EagleEye" <[email-masked]>
Date: Tue, 28 Aug 2001 19:59:13 -0500

Okay, found it... "VCVARS32.BAT" in the vc98/bin/ folder

When I run it, I get "Out of environment space" errors. :(

---

From: "Vianney Lecroart" <[email-masked]>
Date: Wed, 29 Aug 2001 10:06:27 +0200

> When I run it, I get "Out of environment space" errors. :(

You have to put this .bat in your autoexec.bat and reboot your computer.
After windows booting, open a dos window and type "nmake". If it says that
it's an unknown commands, the .bat didn't worked and in this case, take a
look in the microsoft web site. If i says "Microsoft (R) Program Maintenance
Utility   Version 6.00.8168.0", it s ok, just restart the STLport
compilation procedure.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: "EagleEye" <[email-masked]>
Date: Wed, 29 Aug 2001 07:46:40 -0500

Nah, I just increased the environment space on my MS DOS shortcut (don't use
start>run>command.com) to the max (hehe, 4k).

After that, it all worked flawlessly, and I was able to:
nmake clean all (heh, took about an hour!)
then nmake install...

I have the libs now and am very happy. :)

---

From: Gil Colgate <[email-masked]>
Date: Wed, 29 Aug 2001 08:37:25 -0700

Fix this by putting a line like

shell=c:\command.com /e:1024 /p

in your config.sys (assuming your command.co is in C:\)

There is documentation about 'setting environment space in DOS' somewhere on
microsoft's web site