Subject: [Nel] Libxml

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Fri, 5 Oct 2001 15:54:01 +0200

Hi,

NeL has a new external dependence:

NLMISC now needs libxml2 to link properly.

http://xmlsoft.org/

We have added an XML stream to serialize more intelligible data.
Final version of the data can be serialised with a binary stream to save
place and read performance.

Stream interface has been increased to add XML node declaration, node
properties and XML comments.

libxml2 is easy to compile and install.
To avoid some unneeded dependencies, undef those macro in the config file:

#define LIBXML_FTP_ENABLED
#define LIBXML_HTTP_ENABLED

All works fine under windows.
Cedric works on the installation process under linux.

Regards,

Cyril Corvazier
---
Lead 3d programmer
Nevrax France

---

From: Cedric Valignat <[email-masked]>
Date: Fri, 12 Oct 2001 14:06:11 +0200

Hi all,

> Cedric works on the installation process under linux.

That was done few days ago, and i forgot to post a message on that ...

If you got the following error, when launching NeL's configure script,
relaunch it with the '--disable-xmltest' option :

    checking for libxml - version >= 2.0.0... no
    *** Could not run libxml test program, checking why...
    *** The test program failed to compile or link. See the file config.log
    for the
    *** exact error that occured. This usually means LIBXML was incorrectly
    installed
    *** or that you have moved LIBXML since it was installed. In the latter
    case, you
    *** may want to edit the xml2-config script: /usr/bin/xml2-config
    configure: error: libxml2 must be installed.

Have fun.

-- 
Cedric