Subject: [Nel] Gl driver

From: "Cyril Corvazier" <[email-masked]>
Date: Thu, 18 Jan 2001 15:01:25 +0100

<from Snowballs mailing list>

Hi,

> here is the error:
> ERR client.cpp 2574: Exception: EBadDisplay: Missing Required GL extension:
> GL_ARB_multitexture

The NeL's GlDriver works only if the GL_ARB_multitexture and GL_EXT_tex_env_combine are present.
If you don't have those extensions but your card can do multitexturing (if you have GL_SGIS_multitexture 
for exemple), try to update your driver.

Today, the client has been tested under Geforce and Geforce II.

Regards

Cyril Corvazier.

---

From: "Jerome Lanquetot" <[email-masked]>
Date: Thu, 18 Jan 2001 18:01:22 +0100

I have some problems launching the five services: log, login, moves, naming and time.
I found nowhere some help about the functionnalities about each service and the order in which they start.

Could you help me to launch correctly the services.

Regards

Jérôme Lanquetot

---

From: "Vianney Lecroart" <[email-masked]>
Date: Thu, 18 Jan 2001 18:19:46 +0100

>Could you help me to launch correctly the services.

first, you have to create the ns.cfg file with:

--------begin of ns.cfg-------
Host="your nameservice ip";
Port=50000;
--------end of ns.cfg-------

after, you launch, in order:
- naming                   <-- used to find a specific service by his name
- log                         <-- centralized log for all service
- time                       <-- centralized time reference
- login                      <-- centralized user account for all shard
- moves                   <-- a shard

of course, some services will create some config file that you have to fill.
you have to put in the ls.txt the moves service host ip like this:

----
Shards = {
 "your moves service host ip", "the name of the shard appears on the client"
};
----

Vianney Lecroart

---

From: "Jerome Lanquetot" <[email-masked]>
Date: Thu, 18 Jan 2001 18:50:22 +0100

Thanks Vianney,

I have now two bugs.

- The first one is when i launch the moves service, it closes itself.
- The second one (linked to the first one i guess) is when i launch the client i get the following exception:
"01/01/18 18:45:00 ERR client.cpp 2574: Exception: toto2"

I give you all my config files:

ls.txt:

Users = {
};

Shards = {
 "172.16.2.11", "StartPosition"
};

ns.cfg:

Host="jlt";
Port=50000;

and client.cfg:
// CLIENT CONFIG FILE

FullScreen = 0;
Width = 800;
Height = 600;
Depth = 16;
Position = { 1840.000000, -970.000000, -23.520323 };
Heading = { -0.122154, 1.000000, 0.0 };
Background = { 100, 100, 255 };
DataPath = "data/";
FontName = "n019003l.pfb";
LanguageIndex = 0;
LSHost = "172.16.2.11";
Login = "jaylee";
Password = "a";
ShardIP = "172.16.2.11";
CharacterIndex = 0;
LandscapeTileNear = 50.000000;
LandscapeThreshold = 0.001000;

----- Original Message ----- 
From: "Vianney Lecroart" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 18, 2001 6:19 PM
Subject: Re: [Nel] Server

> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>

---

From: robofly <[email-masked]>
Date: Thu, 18 Jan 2001 11:02:44 -0800

Hi Jerome,

Thursday, January 18, 2001, 9:50:22 AM, you wrote:
JL> - The first one is when i launch the moves service, it closes itself.

You might have to use the host name of your
computer instead of the IP number in ls.txt.

Maybe you should also use the host name instead
of the IP number in the LSHost parameter in the
client.cfg

JL> - The second one (linked to the first one i guess) is when i launch the client i get the following exception:
JL> "01/01/18 18:45:00 ERR client.cpp 2574: Exception: toto2"

This is probably because the client can't connect
to the moves_service, that was not started...

Warm regards,
Róbert

---

From: "Jerome Lanquetot" <[email-masked]>
Date: Fri, 19 Jan 2001 09:18:23 +0100

Hi,

The problem remains the same, the moves service closes itself. I use the
host name of my machine, and it doesn't work. I think the best is to send us
your two config files (ls.txt and ns.cfg) used for your server.

Is there a log file or window to see what is wrong?

thanks

Jerome

----- Original Message -----
From: "robofly" <[email-masked]>
To: "Jerome Lanquetot" <[email-masked]>
Sent: Thursday, January 18, 2001 8:02 PM
Subject: Re[2]: [Nel] Server

> JL> - The second one (linked to the first one i guess) is when i launch

---

From: "Vianney Lecroart" <[email-masked]>
Date: Fri, 19 Jan 2001 16:21:48 +0100

Hello,

please, could you stop to send your email in HTML format?
it s not safe and not really cool to read them on text mail program. thank
you.

>"01/01/18 18:45:00 ERR client.cpp 2574: Exception: toto2"

ok, if your moves serive is not launch, you *cant* connect your client, so
the second problem
is because of that. if your moves service closes itself, it s surely because
the login service
didn't authorized him to be an official shard. official shard are in ls.txt
file (Shard variable) and
for a strange reason, the ip you put on it isn t the same that the one who
sent by the moves service.

all services log informations in a file called logs.log, you should take a
look on it.

Vianney Lecroart

---

From: robofly <[email-masked]>
Date: Fri, 19 Jan 2001 17:19:05 -0800

Hi Jerome,

Friday, January 19, 2001, 12:18:23 AM, you wrote:
JL> The problem remains the same, the moves service closes itself. I use the
JL> host name of my machine, and it doesn't work. I think the best is to send us
JL> your two config files (ls.txt and ns.cfg) used for your server.

One hint: If you can, rename your computer
to "pctest" and try running the servers.
This is a default hostname in the NeL code.
You should be able to override this with
the ns.cfg file.

Also I had some problems with DNS issues, the
test computer I was using didn't have a
legal host name that could be looked up,
after I fixed that everything worked...

Warm regards,
Robert

<<<<<ns.cfg>>>>>>
Host="pctest";
Port=50000;
>>>>>ns.cfg<<<<<<