Subject: [Nel] some questions about buildings Nel under win32

From: Nicolas Hognon <[email-masked]>
Date: Wed, 17 Jan 2001 23:08:35 +0100

hello (sorry for my english)

i've got problem to build the client under win32.
i build all the nel components and stl-port and freetype.
then i build the client and i've got some problem at the link.

here is the error log of visual.

 > Linking...
 > MSVCRTD.lib(cinitexe.obj) : warning LNK4098: defaultlib "libcmt.lib"
 > conflicts with use of other libs; use /NODEFAULTLIB:library
 > freetype.lib(ftinit.obj) : error LNK2001: unresolved external symbol
 > _psaux_module_class
 > Debug/snowballs.exe : fatal error LNK1120: 1 unresolved externals
 > Error executing link.exe.

perhaps i make a mistake building freetype.
i've got freetype-2.0.1 which generate freetype200b8_D.lib (debug)
and freetype200b8MT.lib (release) in the lib directory.

i try to link with the debug and the release one renaming it to 
freetype.lib cos the client link with freetype.lib
but it don't work.
i read different message in the mailing list and i understand the 
freetype lib is build in obj directory but one my system it's build in lib.
is it possible i've got a wrong version of freetype ?

thank you for you're help.

and i've got another question a the 0.1 release of nel client and 
server. where are the data. in another module than code.
cos i can see data on the webcvs but i can't get it with wincvs ?

-- 
Nicolas Hognon
home : [email-masked]         / www.cblt.org
work : [email-masked] / www.virtools.com
#ICQ : 36044443

Enjoy the silence
(DM)

---

From: "Jerome Lanquetot" <[email-masked]>
Date: Thu, 18 Jan 2001 10:38:36 +0100

You have to add the psaux files in the freetype project (do it manually it
works)

----- Original Message -----
From: "Nicolas Hognon" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, January 17, 2001 11:08 PM
Subject: [Nel] some questions about buildings Nel under win32

> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>

---

From: "Vianney Lecroart" <[email-masked]>
Date: Thu, 18 Jan 2001 10:48:39 +0100

> and freetype200b8MT.lib (release) in the lib directory.

when we compile freetype2.0.1, it generated a freetype.lib in the
freetype-2.0.1/obj directory.
we never rename the library name or something like that.
we don t have freetype200b8MT.lib or these strange lib filename.
it seems with the name that it s freetype version 2.0.0 beta 8 and it s
perhaps the reason.

> cos i can see data on the webcvs but i can't get it with wincvs ?

no, we don t put the data on cvs because it s too slow to get them and
binaries are
not very well managed in cvs. if you want data for the snowballs game, you
have to
download the tarball or zip file from the www.nevrax.org web site.

Vianney