Subject: [Nel] Unable to compile nelns on linux

From: David Mentre <[email-masked]>
Date: 12 Jan 2002 23:10:16 +0100

Hello,

One again, a bad news. After updating to the latest nelns code, I am now
unable to compiled it (on debian 3.0):

david@oops:~/pub/NeL/code/nelns$ ./configure --with-stlport=/usr/local/Installed/STLport4.5/ --with-stlport-include=/usr/local/Installed/STLport4.5/include/stlport --with-stlport-lib=/usr/local/Installed/STLport4.5/lib/ --with-nel=/usr/local/Installed/NeL/ --with-nel-lib=/usr/local/Installed/NeL/lib --prefix=/usr/local/Installed/NeL/
[...]
checking for -lnelmisc... yes
[...]

david@oops:~/pub/NeL/code/nelns$ nice make
[...]
make[2]: Entering directory `/home/david/pub/NeL/code/nelns/login_service'
/bin/sh ../libtool --mode=link c++  -O3 -DNL_RELEASE   -D_REENTRANT -I/usr/local/Installed/STLport4.5/include/stlport -I/usr/local/Installed/NeL//include  -o login_service  connection_client.o connection_ws.o login_service.o -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.5/lib/  -lstlport_gcc 
c++ -O3 -DNL_RELEASE -D_REENTRANT -I/usr/local/Installed/STLport4.5/include/stlport -I/usr/local/Installed/NeL//include -o login_service connection_client.o connection_ws.o login_service.o  -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.5/lib/ -lstlport_gcc
/usr/bin/ld: cannot find -lnelmisc
collect2: ld returned 1 exit status

Adding -L/usr/local/Installed/NeL/lib allows the compilation:

/bin/sh ../libtool --mode=link c++  -O3 -DNL_RELEASE   -D_REENTRANT -I/usr/local/Installed/STLport4.5/include/stlport -I/usr/local/Installed/NeL//include  -o login_service  connection_client.o connection_ws.o login_service.o -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.5/lib/  -L/usr/local/Installed/NeL/lib -lstlport_gcc

As something been changed recently in the nelns/configure scripts?

Best regards,
d.

PS : I have added path to NeL and STLports libraries in
     ld.so.conf. Could it explain this bad behavior? I don't think so.

david@oops:~/pub/NeL/code/nelns$ cat /etc/ld.so.conf 
/usr/X11R6/lib
/usr/local/Installed/NeL/lib
/usr/local/Installed/STLport4.5/lib

-- 
 [email-masked]

---

From: "Daniel Miller" <[email-masked]>
Date: Tue, 15 Jan 2002 11:32:14 +0100

Cedric updated the scripts last week - he's on holiday this week and I'm
affraid we're a bit snowed under so we're unlikely to have time to look into
this 'till he gets back.

Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
David Mentre
Sent: Saturday, January 12, 2002 11:10 PM
To: [email-masked]
Subject: [Nel] Unable to compile nelns on linux

Hello,

david@oops:~/pub/NeL/code/nelns$
./configure --with-stlport=/usr/local/Installed/STLport4.5/ --with-stlport-i
nclude=/usr/local/Installed/STLport4.5/include/stlport --with-stlport-lib=/u
sr/local/Installed/STLport4.5/lib/ --with-nel=/usr/local/Installed/NeL/ --wi
th-nel-lib=/usr/local/Installed/NeL/lib --prefix=/usr/local/Installed/NeL/
[...]
checking for -lnelmisc... yes
[...]

david@oops:~/pub/NeL/code/nelns$ nice make
[...]
make[2]: Entering directory `/home/david/pub/NeL/code/nelns/login_service'
/bin/sh ../libtool --mode=link
c++  -O3 -DNL_RELEASE   -D_REENTRANT -I/usr/local/Installed/STLport4.5/inclu
de/stlport -I/usr/local/Installed/NeL//include  -o login_service
connection_client.o connection_ws.o
login_service.o -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.5
/lib/  -lstlport_gcc
c++ -O3 -DNL_RELEASE -D_REENTRANT -I/usr/local/Installed/STLport4.5/include/
stlport -I/usr/local/Installed/NeL//include -o login_service
connection_client.o connection_ws.o
login_service.o  -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.
5/lib/ -lstlport_gcc
/usr/bin/ld: cannot find -lnelmisc
collect2: ld returned 1 exit status

/bin/sh ../libtool --mode=link
c++  -O3 -DNL_RELEASE   -D_REENTRANT -I/usr/local/Installed/STLport4.5/inclu
de/stlport -I/usr/local/Installed/NeL//include  -o login_service
connection_client.o connection_ws.o
login_service.o -lnelmisc -lnelnet -lcrypt -L/usr/local/Installed/STLport4.5
/lib/  -L/usr/local/Installed/NeL/lib -lstlport_gcc

Best regards,
d.

--
 [email-masked]
_______________________________________________
Nel mailing list
[email-masked]
/mailman/listinfo.cgi/nel

---

From: Ian Cahoon <[email-masked]>
Date: Tue, 15 Jan 2002 03:01:14 -0800

I managed to get it working in the last week without any
build system changes on redhat 7.2.

I do see libnelmisc in my linkers's cache:

$ /sbin/ldconfig -p | grep nelmisc
	libnelmisc.so.0 (libc6) => /usr/local/lib/libnelmisc.so.0
	libnelmisc.so (libc6) => /usr/local/lib/libnelmisc.so

--Ian

---

From: Cedric Valignat <[email-masked]>
Date: Tue, 22 Jan 2002 16:24:31 +0100

Hello David,

I rewrote the configure script of NeL, NeLNS, and Snowballs there is 3
weeks ago and i, apparently, didn't test it enought before comiting the
new files, so there was a bug with the --with-nel-lib, sorry about that ...

I fixed it and that will be available on the public cvs tonigth.

The changes that i made on the configure scripts are a mostly complete
rewrite of them. I put all the macros in a acinclude.m4 file placed in
the $CVSROOT/code directory and i created symbolic links inside the cvs
repository in the $CVSROOT/code/{nel,nelns,snowballs2} directories to
that file.

Thanks a lot for your help :-)

Cedric.

---

From: David MENTRE <[email-masked]>
Date: 24 Jan 2002 20:00:33 +0100

Hi Cedric,

> I fixed it and that will be available on the public cvs tonigth.

It does not seem to be fixed:

Even if the libraries are correctly found:

david@oops:~/pub/NeL/code/nelns$ ./configure --with-stlport=/usr/local/Installed/STLport4.5/ --with-stlport-include=/usr/local/Installed/STLport4.5/include/stlport --with-stlport-lib=/usr/local/Installed/STLport4.5/lib/ --with-nel=/usr/local/Installed/NeL/ --prefix=/usr/local/Installed/NeL/
[...]
checking for -lnelmisc... yes
checking for -lnelnet... yes

BTW, speaking of the configure scripts, why is it necessary to give all
--with-stlport, --with-stlport-include and --with-stlport-lib options? I
though that a single --with-stlport would be sufficient.

For example:
david@oops:~/pub/NeL/code/nelns$ ./configure --with-stlport=/usr/local/Installed/STLport4.5 --with-nel=/usr/local/Installed/NeL/ --prefix=/usr/local/Installed/NeL/
[...]
checking for STLPort headers... no
checking for STLPort libraries... /usr/local/Installed/STLport4.5/lib
configure: error: STLPort must be installed (http://www.stlport.org).

It works if I give also -lib and -include options.

Sorry for the always bad news,
Best regards,
d.
-- 
 [email-masked]

---

From: David MENTRE <[email-masked]>
Date: 24 Jan 2002 20:44:39 +0100

> It does not seem to be fixed:

Oops!! Sorry, you effectively fixed it. I just forgot to run
nelns/bootstrap before recompiling.

Once again, sorry for the wrong bug report,
Best regards,
d.
-- 
 [email-masked]

---

From: Cedric Valignat <[email-masked]>
Date: Mon, 28 Jan 2002 14:38:19 +0100

Hi David,

> Once again, sorry for the wrong bug report,

No problems :-)

> though that a single --with-stlport would be sufficient.

--with-stlport is sufficient. The configure script will will automatically
set the STLPort include directory to <STLPort_Diretory>/stlport and the
stlport STLPort lib directory to <STLPort_Diretory>/lib ...

Is the run of the bootstrap fix that problem too ?

I cannot reproduce it, it works fine on my computer :

   $ ~/cvs/code/nel/configure --with-stlport=/home/valignat/installs/STLport-4.5.1 --with-python-version=2
   loading cache ./config.cache
   [...]
   checking for STLPort headers... /home/valignat/installs/STLport-4.5.1/stlport
   checking for STLPort libraries... /home/valignat/installs/STLport-4.5.1/lib
   [...]

Cedric.

---

From: Cedric Valignat <[email-masked]>
Date: Mon, 28 Jan 2002 16:01:37 +0100

Oops ... i just realized that i didn't manage the fact the STLPort
headers could be installed in an 'include' directory (doh ! :-) ... i fixed
it and it will be in the public CVS tonight.

Thanks for the bug report :-)

-- 
Cedric

    Frappe ta tête contre une cruche. Si tu obtiens un son creux,
    n'en déduis pas que c'est forcément la cruche qui est vide.

                                                       Lao Tseu.