Subject: [Nel] ugh, C++ is so obtuse

From: [email-masked]
Date: Mon, 12 Mar 2001 17:26:56 -0800 (PST)

Building latest CVS I get the following:

client.cpp:433: cannot declare variable `ChatDisplayer' to be of type `CChatDisplayer'
client.cpp:433:   since the following virtual functions are abstract:
/usr/local/include/nel/misc/displayer.h:62:     void NLMISC::IDisplayer::doDisplay(long int, NLMISC::CLog::TLogType, const _STL::string &, const char *, int, const char *)

Anybody else getting this?  I'll figure it out myself if I'm the only
one,  Otherwise I'd prefer to let someone who knows C++ deal with it.

Robert

-- 
Robert de Forest      " meetings, n.:
System Administrator         A place where minutes are kept 
Got.net                                and hours are lost."
<[email-masked]>                    -- login fortune

---

From: "Michael Warnock" <[email-masked]>
Date: Mon, 12 Mar 2001 20:01:12 -0800

I got the same problem, you just beat me to reporting it:)

Michael Warnock
In-Orbit Entertainment Inc.
No matter where you go, &this.
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Monday, March 12, 2001 5:26 PM
Subject: [Nel] ugh, C++ is so obtuse

> /usr/local/include/nel/misc/displayer.h:62:     void
NLMISC::IDisplayer::doDisplay(long int, NLMISC::CLog::TLogType, const
_STL::string &, const char *, int, const char *)
> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel

---

From: "Vianney Lecroart" <[email-masked]>
Date: Tue, 13 Mar 2001 10:39:36 +0100

the fix is:
client.cpp line: 413
change:
 virtual void display (time_t date, NLMISC::CLog::TLogType logType, const
std::string &processName, const char *fileName, sint line, const char
*message)
to:
 virtual void doDisplay (time_t date, NLMISC::CLog::TLogType logType, const
std::string &processName, const char *fileName, sint line, const char
*message)

and let s rock'n roll.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: Pierre Bonnefoy <[email-masked]>
Date: Wed, 14 Mar 2001 09:33:13 +0100

OK, I had the same problem as 'Robert' and Michael Warnock.

Thank you Vianney for the fix, although, now, I have a different problem
when compiling the client:

c++ -I/usr/local/include/freetype2 -I/home/pierre/STLport-4.0/stlport -g -O2
  -o client  character_interface.o client.o language_interface.o
login_interface.o move_listener.o pb_message_box.o player_view.o
shards_list_interface.o sight.o
lens_flare.o -lnelnet -lnelmisc -lnel3d -L/usr/local/lib -lfreetype -L/home/
pierre/STLport-4.0/lib  -lstlport_gcc
/usr/local/lib/libnel3d.so: undefined reference to
`NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat, NLMISC::CQuat> type_info node'
/usr/local/lib/libnel3d.so: undefined reference to
`NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat, NLMISC::CQuat>::getValue(void)
const'
/usr/local/lib/libnel3d.so: undefined reference to
`NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat, NLMISC::CQuat> type_info
function'
/usr/local/lib/libnel3d.so: undefined reference to
`NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat, NLMISC::CQuat> virtual table'
/usr/local/lib/libnel3d.so: undefined reference to
`NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat,
NLMISC::CQuat>::evalKey(NL3D::CKeyQuat const *, NL3D::CKeyQuat const *,
float, float, float)'
collect2: ld returned 1 exit status

I have also a problem when compiling the server, but there are many many
error reports (file included).
Moreover, I have a little problem first when compiling server : There is
no --with-python option in configure, and, first, there was a problem as
Python.h was not found. I added by and in makefile the path towards Python.h
and subsequent files.
Shouldn't --with-python option be included also in configure for server ?

As a conclusion, I would like to thank people fom Nevrax and every people
involved in Nevrax.org for such a great job !

     Pierre Bonnefoy

[Moderation note: attached file removed for posting in the mailing list]

---

From: Cedric Valignat <[email-masked]>
Date: Wed, 14 Mar 2001 12:15:57 +0100

Hi,

Pierre Bonnefoy wrote:
> [...]

NeL's headers files are under heavy reorganization so we decide to freeze
the development of the client until it's finished.

So i strongly recommend to use the last Snowball release, Snowball 0.2, 
which can be download on 

> error reports (file included).

i'm going to take a look on that ...

> Shouldn't --with-python option be included also in configure for server ?

It's on my task list for a long time, sorry about that, I will do it
today ...

> involved in Nevrax.org for such a great job !

Thanks :-)

Cedric.

---

From: "Cyril Corvazier" <[email-masked]>
Date: Wed, 14 Mar 2001 16:57:42 +0100

> `NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat, NLMISC::CQuat> type_info
node'
> `NL3D::CTrackKeyFramerLinear<NL3D::CKeyQuat,
NLMISC::CQuat>::getValue(void)
> const'

I have fixed that bug. It should be on the cvs tonight (GMT+1).

*** For c++ addicts, here is the problem ***

The link failed under GCC when we use non-inline functions in a template
implementation.
No problem with Visual C++ 6.0.

It looked like this:

in the .h file:
-----------

// Two template classes
template<class T>
class a
{
    virtual void toto()=0;
};

template<class T>
class b : public a<T>
{
    virtual void toto()
    {
        ...
    };
};

// The second one is implemented, but toto function body is in the .cpp
file.
class b<int> : public a<int>
{
    virtual void toto();
};

In the .cpp:
-----------
virtual void b<int>::toto()
{
    ...
};

The fixe was to let the toto body inline in the header.

Any comments ?

---
Cyril Corvazier
Lead 3d programmer
Nevrax France

---

From: [email-masked]
Date: Wed, 14 Mar 2001 16:23:43 -0800 (PST)

[Charset iso-8859-1 unsupported, filtering to ASCII...]
> No problem with Visual C++ 6.0.

What is your programming environment like?  Do you have equal parts
Windows and Unix develovers?  What kind of testing do you have?
Judging by the dates in CVS it looks like you've been developing for
about five months, is this correct?  Is all of your development staff
focused on the GPL'd parts right now, or is some development already
underway for the proprietary content (game code)?

Is someone over there working on documentation?  Is there a public
document describing your objectives and plans?

I'm also still curious in which ways the non-nevrax community can best
assist your efforts.  It seems the bug reports and patches are
well-received, but without much documentation it's hard to tell where
our efforts are most needed.

Thanks!

Robert

---

From: "Pierre Bonnefoy" <[email-masked]>
Date: Thu, 15 Mar 2001 18:37:39 +0100

OK, thanks a lot for your explanations.

Downloaded this morning code on CVS, and library and client compile well
(although I have still problems with server side).
My problem now is to get a conf to be able to use the game, because I get
0.5 fps with mine (PIII 500 + 128 MB RAM + Matrox G200 + Linux).

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]]De la part de
Cyril Corvazier
Envoyé : mercredi 14 mars 2001 16:58
À : [email-masked]
Objet : Re: [Nel] ugh, C++ is so obtuse

node'

It looked like this:

in the .h file:
-----------

// Two template classes
template<class T>
class a
{
    virtual void toto()=0;
};

template<class T>
class b : public a<T>
{
    virtual void toto()
    {
        ...
    };
};

In the .cpp:
-----------

Any comments ?

---
Cyril Corvazier
Lead 3d programmer
Nevrax France

---

From: Cedric Valignat <[email-masked]>
Date: Wed, 28 Mar 2001 19:53:19 +0200

[email-masked] wrote:
> 
> What is your programming environment like?

On Windows computers :

   Windows 2000
   Visual C++ 6.0
   WinCVS and TortoiseCVS

On GNU/Linux computers :

   Debian, Redhat and Mandrake distributions
   GCC 2.95.2 and 2.96 (yes i now :-)
   Emacs, XEmacs, or kdevelop
   DDD / GDB

> Do you have equal parts Windows and Unix develovers?

Most of us are working on Windows, the VC++ debuging system is a lot more
appreciated by some of us :-)

> What kind of testing do you have?

We have two major way of testing our work :

   using Snowball as a test program
   and / or writing small applications to test specific functionalities.

It's very basic :-)

> about five months, is this correct?

We started coding approximately 10 months ago. We developed some code
to make some tests to make some decisions about the technologie to
use and some other points ...

> Is all of your development staff focused on the GPL'd parts right
> now, or is some development already underway for the proprietary
> content (game code)?

We have been working on the our game code for some time now, so we are
currently working on both parts, GPL and proprietary code.

> document describing your objectives and plans?

We are currently working on the documentation, and we should be able to
make our work available soon ;-)

> our efforts are most needed.

Our documentions will include a roadmap and other related documents, so
you should be able get a better idea on what we are doing and on what
we plan to work on ...

Cedric.