Subject: [Nel] STLPort...

From: "Brenden Towey" <[email-masked]>
Date: Wed, 28 Feb 2001 21:45:35 -0800

Ok, first post.  Sorry I didn't go through the archives, I'm just lazy that way.

What is STLPort and where do I get it?  www.stlport.org is not found by google (so it therefore can't exist ;-).  I'm of course referring to the compile time #error in nl_types.h:
#  error "You need STLPort to compile this project (www.sltport.org)"

Do I just add -D__SGI_STL_PORT to the command line or is there an additional component that I need to get?

Thanks for any help you can give!

Brenden
non-uber NeL lurker

---

From: Dim Segebart <[email-masked]>
Date: Thu, 1 Mar 2001 12:26:22 +0100

Hope you'll find STL here
http://www.sgi.com/tech/stl/

Thursday, March 01, 2001, 6:45:35 AM, you wrote:

BT> Ok, first post.  Sorry I didn't go through the archives, I'm just lazy that way.

BT> What is STLPort and where do I get it?  www.stlport.org is not found by google (so it therefore can't exist ;-).  I'm of course referring to the compile time #error in nl_types.h:
BT> #  error "You need STLPort to compile this project (www.sltport.org)"

BT> Do I just add -D__SGI_STL_PORT to the command line or is there an additional component that I need to get?

BT> Thanks for any help you can give!

BT> Brenden
BT> non-uber NeL lurker

-- 
Dim Segebart                         mailto:[email-masked]

---

From: Valignat Cedric <[email-masked]>
Date: Thu, 1 Mar 2001 14:17:37 +0100

Hi Brenden,

> #  error "You need STLPort to compile this project (www.sltport.org)"

STLPort is an open-source library that build a complete, multiplatform ANSI C++
Standard library with SGI STL with a better debug mode and some extensions.

You will find it on the following web site :-)

   <URL:http://www.stlport.org/>

> Do I just add -D__SGI_STL_PORT to the command line or is there an additional component that I need to get?

You should check the INSTALL file, it's describe all the requirements (and
where to find them) and explain how to compile the beast on GNU/Linux an on
Windows platforms.

> Thanks for any help you can give!

You are welcome ...

Have fun :-)

Cedric.