Subject: [Nel] Cannot connect to itsalive.nevrax.org

From: "Dee" <[email-masked]>
Date: Thu, 8 Nov 2001 00:52:51 +1100

Hi, 

I have just got the snowball2 client running.  I try to connect to the server (itsalive.nevrax.org) that you mentioned in last email.  But I either receive a 10051:network is unreachable, or 10060: Connection timed-out.

The following is the log:

Log Starting [01/11/08 00:14:23]
01/11/08 00:14:23 INF: Starting Snowballs 1
01/11/08 00:14:30 INF: Welcome to Snowballs
01/11/08 00:14:30 INF: 
01/11/08 00:14:30 INF: Press SHIFT-ESC to exit the game
01/11/08 00:14:39 INF: static const char *OtherSideAssociations[] = {
01/11/08 00:14:39 INF:  "AA",
01/11/08 00:14:39 INF:  "RA",
01/11/08 00:14:39 INF:  "RAA",
01/11/08 00:14:39 INF:  "VLP",
01/11/08 00:14:39 INF:  "SCS",
01/11/08 00:14:39 INF: };
01/11/08 00:14:40 WRN: Exception will be launched: Socket error: Connection closed (0)
01/11/08 00:14:40 INF: Report for blocking socket itsalive.nevrax.org:49999 (195.68.21.196): Max send time: 0 Max recv time: 683
01/11/08 00:14:40 INF: Max send time: 0
01/11/08 00:14:59 INF: static const char *OtherSideAssociations[] = {
01/11/08 00:14:59 INF:  "AA",
01/11/08 00:14:59 INF:  "RA",
01/11/08 00:14:59 INF:  "RAA",
01/11/08 00:14:59 INF:  "VLP",
01/11/08 00:14:59 INF:  "SCS",
01/11/08 00:14:59 INF: };
01/11/08 00:15:03 WRN: Exception will be launched: Socket error: Connection closed (0)
01/11/08 00:15:03 INF: Report for blocking socket itsalive.nevrax.org:49999 (195.68.21.196): Max send time: 0 Max recv time: 3831
01/11/08 00:15:03 INF: Max send time: 0
01/11/08 00:15:03 INF: addr:192.168.100.4:37000 cookie:'3711608011|2513154061|8'
01/11/08 00:15:24 WRN: Exception will be launched: Socket error: Connection to 192.168.100.4:37000 (192.168.100.4) failed (10060: Connection timed-out)
01/11/08 00:15:38 INF: Report for blocking socket :0 (0.0.0.0): Max send time: 0 Max recv time: 0
01/11/08 00:15:38 INF: Max send time: 0

I am running the release version.  And when I start the client, why it said "Snowballs 1", but not "Snowballs 2".  Is this correct?

I have set up a server on a Linux machine.  But when I try to connect to it, there is an error saying that there is no front end service running.  Then I try to start "sno_frontend", but it just say cannot locate "libnelnet.so" (??? I forgot what's the file name, I am not around the Linux machine right now).

Thanks!!

Wilson

---

From: "Vianney Lecoart" <[email-masked]>
Date: Wed, 7 Nov 2001 14:56:04 +0100

Hi Wilson,

>I have just got the snowball2 client running.  I try to connect to the
server (itsalive.nevrax.org) that you mentioned in last email.  But I either
receive a 10051:network is unreachable, or 10060: Connection timed-out.

Normal, it was a problem in the linx configuration, it's now fixed and
should work fine.

> I am running the release version.  And when I start the client, why it
said "Snowballs 1", but not "Snowballs 2".  Is this correct?

Okay, It's the first version of the new snowballs. We rewrite it from
scratch so we call it snowballs 2 but it's the first version. Anyway, it's
the new snowballs :)

>I have set up a server on a Linux machine.  But when I try to connect to
it, there is an error saying that there is no front end service running.

Right, the frontend crashed so no other frontend was available (I relaunch
it).

> Then I try to start "sno_frontend", but it just say cannot locate
"libnelnet.so" (??? I forgot what's the file name, I am not around the Linux
machine right now).

I think the problem is that you don't put the directory where the os can
find the dynamic library libnelnet. You have to set it in the
LD_LIBRARY_PATH.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?