Subject: [Nel] buildig nel/snowballs

From: "Ruud Verdonck" <[email-masked]>
Date: Sun, 4 Nov 2001 17:31:42 +0100

Hi,

I'm new to nel and c++,

i just tried to compile snowballs 2, but i get link errors (prolly something to do with STLport)

here are some snippets:

naming_service.obj : error LNK2001: unresolved external symbol "public: class _STL::basic_string<char,class _STL::char_traits<char>,class _STL::allocator<char> > __thiscall NLNET::CBufSock::asString(void)const " (?asString@CBufSock@NLNET@@QBE?AV?$ba
sic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@XZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: class _STL::basic_string<char,class _STL::char_traits<char>,class _STL::allocator<char> > __thiscall NLNET::CInetAddress::asString(void)const " (?asString@CInetAddress@NLNET@@QB
E?AV?$basic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@XZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: void __cdecl NLMISC::CLog::displayNL(char const *,...)" (?displayNL@CLog@NLMISC@@QAAXPBDZZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: void __thiscall NLMISC::CLog::setPosition(int,char *)" (?setPosition@CLog@NLMISC@@QAEXHPAD@Z)
naming_service.obj : error LNK2001: unresolved external symbol "class NLMISC::CLog * NLMISC::InfoLog" (?InfoLog@NLMISC@@3PAVCLog@1@A)
naming_service.obj : error LNK2001: unresolved external symbol "void __cdecl NLMISC::createDebug(void)" (?createDebug@NLMISC@@YAXXZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: static void __cdecl NLNET::CNetManager::send(class _STL::basic_string<char,class _STL::char_traits<char>,class _STL::allocator<char> > const &,class NLNET::CMessage const &,clas
s NLNET::CBufSock *)" (?send@CNetManager@NLNET@@SAXABV?$basic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@ABVCMessage@2@PAVCBufSock@2@@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public: void __thiscall NLNET::CInetAddress::serial(class NLMISC::IStream &)" (?serial@CInetAddress@NLNET@@QAEXAAVIStream@NLMISC@@@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall NLMISC::CMemStream::serial(unsigned __int8 &)" (?serial@CMemStream@NLMISC@@UAEXAA_E@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public: virtual void __thiscall NLMISC::CMemStream::serial(class _STL::basic_string<char,class _STL::char_traits<char>,class _STL::allocator<char> > &)" (?serial@CMemStream@NLMISC@@UAEX
AAV?$basic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@@Z)

this is the naming service btw, but i get the same errors with snowballs client,

i installed stlport 4.0, nmake'd it, and installed it, and put the directories in the VC options, above the microsoft ones
i also tried stlport 4.5, i still get the same errors,

Can anyone help?

Ruud Verdonck

---

From: "Vianney Lecoart" <[email-masked]>
Date: Mon, 5 Nov 2001 10:48:47 +0100

Hi Ruud,

> naming_service.obj : error LNK2001: unresolved external symbol "public:
class _STL::basic_string<char,class _STL::char_traits<char>,class
_STL::allocator<char> > __thiscall NLNET::CBufSock::asString(void)const "
(?asString@CBufSock@NLNET@@QBE?AV?$ba

It seems that the project you opened doesn't have dependencies with nel misc
and nel net.
You have to open the file name services.dsw that is in the code/nel/nelns/
directory and not .dsp.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

----- Original Message -----
From: "Ruud Verdonck" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, November 04, 2001 5:31 PM
Subject: [Nel] buildig nel/snowballs

Hi,

I'm new to nel and c++,

i just tried to compile snowballs 2, but i get link errors (prolly something
to do with STLport)

here are some snippets:

naming_service.obj : error LNK2001: unresolved external symbol "public:
class _STL::basic_string<char,class _STL::char_traits<char>,class
_STL::allocator<char> > __thiscall NLNET::CBufSock::asString(void)const "
(?asString@CBufSock@NLNET@@QBE?AV?$ba
sic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@XZ)
naming_service.obj : error LNK2001: unresolved external symbol "public:
class _STL::basic_string<char,class _STL::char_traits<char>,class
_STL::allocator<char> > __thiscall NLNET::CInetAddress::asString(void)const
" (?asString@CInetAddress@NLNET@@QB
E?AV?$basic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@XZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: void
__cdecl NLMISC::CLog::displayNL(char const *,...)"
(?displayNL@CLog@NLMISC@@QAAXPBDZZ)
naming_service.obj : error LNK2001: unresolved external symbol "public: void
__thiscall NLMISC::CLog::setPosition(int,char *)"
(?setPosition@CLog@NLMISC@@QAEXHPAD@Z)
naming_service.obj : error LNK2001: unresolved external symbol "class
NLMISC::CLog * NLMISC::InfoLog" (?InfoLog@NLMISC@@3PAVCLog@1@A)
naming_service.obj : error LNK2001: unresolved external symbol "void __cdecl
NLMISC::createDebug(void)" (?createDebug@NLMISC@@YAXXZ)
naming_service.obj : error LNK2001: unresolved external symbol "public:
static void __cdecl NLNET::CNetManager::send(class
_STL::basic_string<char,class _STL::char_traits<char>,class
_STL::allocator<char> > const &,class NLNET::CMessage const &,clas
s NLNET::CBufSock *)"
(?send@CNetManager@NLNET@@SAXABV?$basic_string@DV?$char_traits@D@_STL@@V?$al
locator@D@2@@_STL@@ABVCMessage@2@PAVCBufSock@2@@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public: void
__thiscall NLNET::CInetAddress::serial(class NLMISC::IStream &)"
(?serial@CInetAddress@NLNET@@QAEXAAVIStream@NLMISC@@@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public:
virtual void __thiscall NLMISC::CMemStream::serial(unsigned __int8 &)"
(?serial@CMemStream@NLMISC@@UAEXAA_E@Z)
naming_service.obj : error LNK2001: unresolved external symbol "public:
virtual void __thiscall NLMISC::CMemStream::serial(class
_STL::basic_string<char,class _STL::char_traits<char>,class
_STL::allocator<char> > &)" (?serial@CMemStream@NLMISC@@UAEX
AAV?$basic_string@DV?$char_traits@D@_STL@@V?$allocator@D@2@@_STL@@@Z)

this is the naming service btw, but i get the same errors with snowballs
client,

i installed stlport 4.0, nmake'd it, and installed it, and put the
directories in the VC options, above the microsoft ones
i also tried stlport 4.5, i still get the same errors,

Can anyone help?

Ruud Verdonck