Subject: [Nel] gl.h

From: "Jared Mark" <[email-masked]>
Date: Sat, 17 Feb 2001 15:13:35 -0600

-- I'm compiling in win98, using MS VC++ 6.0.

I get the following errors:

Compiling...
driver_opengl.cpp
C:\snowballs\nel\src\3d\driver\opengl\driver_opengl_extension.h(44) : fatal error C1083: Cannot open include file: 'GL/glext.h': No such file or directory
driver_opengl_extension.cpp
C:\snowballs\nel\src\3d\driver\opengl\driver_opengl_extension.h(44) : fatal error C1083: Cannot open include file: 'GL/glext.h': No such file or directory
driver_opengl_material.cpp
C:\snowballs\nel\src\3d\driver\opengl\driver_opengl_extension.h(44) : fatal error C1083: Cannot open include file: 'GL/glext.h': No such file or directory
driver_opengl_matrix.cpp
C:\snowballs\nel\src\3d\driver\opengl\driver_opengl_extension.h(44) : fatal error C1083: Cannot open include file: 'GL/glext.h': No such file or directory
driver_opengl_texture.cpp
C:\snowballs\nel\src\3d\driver\opengl\driver_opengl_extension.h(44) : fatal error C1083: Cannot open include file: 'GL/glext.h': No such file or directory
Error executing cl.exe.

Okay, so I go check the code, and I find out there's a comment there telling me to go download something (Shouldn't this sort of thing be in the readme file?)...

#include <GL/glext.h> // Please download it from http://oss.sgi.com/projects/ogl-sample/ABI/"

I go to do that, and there's 2 versions available.  I grab the most recent, and unpack it to a temporary directory so I can go looking for these files, and maybe figure out exactly where I need to put them.

I can find glx.h, but there is no glext.h or gl.h... (both of which are required).

What am I missing?

---

From: "EagleEye" <[email-masked]>
Date: Sat, 17 Feb 2001 15:26:03 -0600

Okay, I did some reading through the mail archives and found the file I needed.  I guess this means the documentation just needs to be updated so people know to get this file (glext.h), and where to get it.

Here's the URL for those of you looking for it:
http://oss.sgi.com/projects/ogl-sample/ABI/glext.h

  ----- Original Message ----- 
  From: Jared Mark 
  To: [email-masked] 
  Sent: Saturday, February 17, 2001 3:13 PM
  Subject: [Nel] gl.h

  Compiling...
  driver_opengl.cpp

  What am I missing?

---

From: Valignat Cedric <[email-masked]>
Date: Mon, 19 Feb 2001 16:51:54 +0100

> http://oss.sgi.com/projects/ogl-sample/ABI/glext.h

There is something about it in the INSTALL file, at the "Requirements" section.
I know that our documentation is far to be complete, and we are working on it,
but you should read the INSTALL file *carefully* before trying to compile NeL,
there is some usefull informations in it ;-)

Cedric.

---

From: "EagleEye" <[email-masked]>
Date: Mon, 19 Feb 2001 15:46:39 -0600

Ahh, right you are.  I skipped over that part because it seemed to still be
under the heading of  "On a GNU/Linux platform you will need the following
libraries and softwares :"... since that doesn't apply to me, I just kinda
let my mind skip over it. :)

----- Original Message -----
From: "Valignat Cedric" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 19, 2001 9:51 AM
Subject: Re: [Nel] gl.h

> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
>

---

From: Valignat Cedric <[email-masked]>
Date: Tue, 20 Feb 2001 10:45:20 +0100

> let my mind skip over it. :)

You right, it isn't very clear, i going to fix that ... :-)

Cedric.