Subject: [Nel] Volatile source, cryptic CVS log entries

From: [email-masked]
Date: Sat, 3 Mar 2001 01:05:59 -0800 (PST)

Hello again folks,

First, I did read that whole message about 'data/', but I couldn't
figure out what the fix was.  I admit my C++ skills are a lacking, but
a patch would have been great.  It doesn't matter now, because I can't
build the latest CVS.

Up until today I couldn't build NeL at all due to library problems, I
think.  When I finally got it to build the client wouldn't build.

So currently I'm getting:

/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver::CMode::CMode(unsigned short, unsigned short, unsigned char, bool)'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::CDriverUser::convMat(NL3D::UMaterial &)'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver::setMatrixMode2D11(void)'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver::setMatrixMode2D43(void)'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver virtual table'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver type_info node'
/usr/local/lib/libnel3d.so: undefined reference to `NL3D::UDriver type_info function'

... which looks to me like more of that interface rearrangement stuff,
and I have no idea what to do about it.

As someone who would very much like to help either with testing, or
even coding, I'd like to request that developers make CVS log entries
a little more verbose then 'grrrrr', 'added file' or 'BUG: makefile'.
I know you guys know what you're doing, and I can usually get some
idea of what's going on looking at the diffs, but if 'grrrr' was 'path
change (3d/tmp)', and 'added file' mentioned the filename, and 'BUG:
makefile' said 'BUG: added frustrum.ccp', it would make it a lot
easier for me to get my bearings and tracedown whether errors are due
to my build environment, or due to some SNAFU in France, or whatever.
It would also make it less likely that I would need to look at the
diff at all.

I love the screenshots, and I can't wait to try this stuff out on my
own machine.  

Robert

-- 
Robert de Forest      " meetings, n.:
System Administrator         A place where minutes are kept 
Got.net                                and hours are lost."
<[email-masked]>                    -- login fortune

---

From: "Lionel Berenguier" <[email-masked]>
Date: Mon, 5 Mar 2001 10:19:25 +0100

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Saturday, March 03, 2001 10:05 AM
Subject: [Nel] Volatile source, cryptic CVS log entries

> change (3d/tmp)', and 'added file' mentioned the filename, and 'BUG:

Ok. I apologize. Actually, the files were moved 2 times, and I just realize
that just the last log is valid.

Sorry...

Lionel Berenguier.
---
3d programmer / nevrax.com

---

From: Cedric Valignat <[email-masked]>
Date: Tue, 6 Mar 2001 15:30:14 +0100

> a patch would have been great.  It doesn't matter now, because I can't

I'm going to take a look on it ...

> [...]

This is fixed in the last CVS files. Update your CVS and it should work :-)

Cedric.