Subject: [Nel] Small bugfix

From: "Anatoly Sennov" <[email-masked]>
Date: Thu, 4 Oct 2001 19:19:49 +0400

Hello, it's really small :-)

Index: service.cpp
===================================================================
RCS file: e:/repositories/warfair/nel/src/net/service.cpp,v
retrieving revision 1.1.1.1
diff -r1.1.1.1 service.cpp
742c742
<    ((CWinDisplayer *)wd)->update ();
---
>    cwd->update ();

========================
wd doesn't contain valid pointer at the time update() is called.

Order of service startup in /nelns/howto should be fixed: log_service looks for the time_service and quits when cannot find it, so time_service should be started _before_ the log_service.

PS. Not yet familiar with all code but am feeling it's a GOOD THING :-)

--AS

---

From: "Vianney Lecroart" <[email-masked]>
Date: Thu, 4 Oct 2001 17:52:38 +0200

Hi Anatoly,

Thanks for the bug report, it should occurs only on windows with dos
application and we always use windows application, it explains why we didn't
have this bug. Anyway, it was fixed and commited.

/nelns/howto is out of date, in fact, log_service isn't used anymore, so you
don't have to launch it :)

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?