Subject: [Nel] Particule assert

From: Loic Dachary <[email-masked]>
Date: Thu, 21 Feb 2002 23:19:09 +0100

Hi,

	I have a constant flow of the following:

AST 3039 particle_system.cpp 169 : "retValue >= 0 && retValue < 10000" dist = 0.000000, _MaxViewDist = 200.000000, _MaxNumFacesWanted = 10000, retValue = 10000.000000

	with todays CVS compiled, on GNU/Linux. The game is otherwise working
fine, including the particle system.

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt

---

From: Alain Dutech <[email-masked]>
Date: Fri, 22 Feb 2002 09:05:32 +0100

Hello,

still have 3 problems to solve :

- constant flow of :
AST12088 particle_system.cpp 169 : "retValue >= 0 && retValue < 10000" dist = 0.000000, _MaxViewDist = 200.000000,
_MaxNumFacesWanted = 10000, retValue = 10000.000000

- constant flow of :
AST12088 debug.h 384 : "dynamic_cast<T>(o)"

- unreadable text (white squares) in the snowball window...

Wish I had more time...

Alain

---

From: Loic Dachary <[email-masked]>
Date: Fri, 22 Feb 2002 11:02:42 +0100

> - unreadable text (white squares) in the snowball window...

	:-) Could you please describe your configuration ? STL version, 
operating system etc.

	For the record I'm using the CVS tree of yesterday and STL-4.5
under Debian GNU/Linux unstable. The text is readable and I do not see
the dynamic_cast<T>(o) asserts. But I do see the particle assert.

	Cheers,

---

From: Alain Dutech <[email-masked]>
Date: Fri, 22 Feb 2002 11:57:50 +0100

Hello again,

>         :-) Could you please describe your configuration ? STL version,

of course, I forgot to mention all that. So...

Red Hat 7.1 GNU/Linux
gcc version 2.96
STLport version 4.5.1
GL_VERSION: 1.2 Mesa 3.4
GL_RENDERER: Mesa DRI Voodoo3 20001101

CVS tree of yesterday too (21/01/2002)

> the dynamic_cast<T>(o) asserts.

Lucky one

> But I do see the particle assert.
>

Unlucky :-)

>         Cheers,

With sympathy
Alain - Still compiling with full debug to know more....

---

From: David MENTRE <[email-masked]>
Date: 24 Feb 2002 20:48:00 +0100

Hello Alain,

> GL_RENDERER: Mesa DRI Voodoo3 20001101

As you, I also observe that the text in the main window is unreadable.

My config:
 Debian Woody 3.0 GNU/Linux on x86
 gcc 2.95.4
 STLport version 4.5.1
 OpenGL version string: 1.2 Mesa 3.4.2
 OpenGL renderer string: Mesa DRI Rage128 20010405 AGP 1x x86/MMX

And for info:
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr, 
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array, GL_EXT_histogram, 
    GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal, 
    GL_EXT_stencil_wrap, GL_EXT_texture3D, GL_EXT_texture_env_add, 
    GL_EXT_texture_object, GL_EXT_texture_lod_bias, GL_EXT_vertex_array, 
    GL_MESA_window_pos, GL_MESA_resize_buffers, GL_NV_texgen_reflection, 
    GL_PGI_misc_hints, GL_SGIS_pixel_texture, GL_SGIS_texture_edge_clamp
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

When starting snowball, I have the following message:
WRN 3248 driver_opengl.cpp 785 : Missing Important GL extension: GL_EXT_texture_env_combine => All envcombine are setup to GL_MODULATE!!!

d.
-- 
 [email-masked]

---

From: "Vianney Lecroart" <[email-masked]>
Date: Mon, 25 Feb 2002 13:59:21 +0100

Hi,

> WRN 3248 driver_opengl.cpp 785 : Missing Important GL extension:
GL_EXT_texture_env_combine => All envcombine are setup to GL_MODULATE!!!

If you don't see the font, the problem is due to this warning. The font
system needs GL_EXT_texture_env_combine extension, and you don't have it so
the font can't be displayed correctly :-/

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: David MENTRE <[email-masked]>
Date: 25 Feb 2002 23:20:28 +0100

> the font can't be displayed correctly :-/

Ooch! Will you try to fix that or consider that all normal NeL users
will have graphic cards with the above mentioned extension?

d.
-- 
 [email-masked]

---

From: "Vianney Lecroart" <[email-masked]>
Date: Tue, 26 Feb 2002 09:57:59 +0100

> will have graphic cards with the above mentioned extension?

We plan to port the 3d lib as many recent 3d card as possible and we could
fix this font problem but it will not be before the midlle/end of summer.
We can add this on the OSS community task list :)

Vianney Lecroart
---

---

From: David MENTRE <[email-masked]>
Date: 26 Feb 2002 23:22:38 +0100

Hello Vianney,

> fix this font problem but it will not be before the midlle/end of

Greet! (However, I don't know if you put my rage128 graphic card in the
recent category ;-)

> We can add this on the OSS community task list :)

I've seen the hint but can't help you for that. I'm a newbie to OpenGL
programming and C++. :(

BTW, I've compiled the latest CVS tree and observed the following
behaviors: 

 - NeL seems slower. Can't give framerate figures as the fonts are
   unreadable but the GNU is definitely more sensitive and less reactive
   to mouse mouvements (i.e. it is hardly playable)

 - code/nel can't be compiled with --enable-ai. Here is the error:

c++ -DHAVE_CONFIG_H -I. -I. -I../../../include -O3 -DNL_RELEASE -ftemplate-depth-24 -Wno-multichar -D_REENTRANT -I/usr/X11R6/include -I/usr/local/Installed/STLport4.5//include/stlport -Wp,-MD,.deps/baseai.pp -c baseai.cpp     -fPIC -DPIC -o .libs/baseai.lo
In file included from ../../../include/nel/ai/agent/ident.h:33,
                 from ../../../include/nel/ai/agent/baseai.h:34,
                 from ../../../include/nel/ai/agent/agent_operator.h:29,
                 from ../../../include/nel/ai/agent/agent_object.h:30,
                 from ../../../include/nel/ai/agent/msg.h:30,
                 from ../../../include/nel/ai/agent/mailbox.h:28,
                 from ../../../include/nel/ai/agent/agentexport.h:49,
                 from baseai.cpp:24:
../../../include/nel/ai/agent/identtype.h: In method `NLAIAGENT::CAgentNumber::CAgentNumber(long long unsigned int, unsigned char, unsigned char)':
../../../include/nel/ai/agent/identtype.h:57: no matching function for call to `NLMISC::CEntityId::CEntityId (uint64 &, uint8 &, uint8 &)'
../../../include/nel/misc/entity_id.h:60: candidates are: NLMISC::CEntityId::CEntityId()
../../../include/nel/misc/entity_id.h:68:                 NLMISC::CEntityId::CEntityId(unsigned char, long long unsigned int, unsigned char, unsigned char)
../../../include/nel/misc/entity_id.h:76:                 NLMISC::CEntityId::CEntityId(unsigned char, long long unsigned int)
../../../include/nel/misc/entity_id.h:84:                 NLMISC::CEntityId::CEntityId(long long unsigned int)
../../../include/nel/misc/entity_id.h:95:                 NLMISC::CEntityId::CEntityId(const NLMISC::CEntityId &)
../../../include/nel/misc/entity_id.h:104:                 NLMISC::CEntityId::CEntityId(NLMISC::IStream &)
../../../include/nel/misc/entity_id.h:118:                 NLMISC::CEntityId::CEntityId(const char *)
../../../include/nel/ai/agent/identtype.h: In method `NLAIAGENT::CAgentNumber::CAgentNumber(long long unsigned int, unsigned char, unsigned char, unsigned char)':../../../include/nel/ai/agent/identtype.h:62: no matching function for call to `NLMISC::CEntityId::CEntityId (uint64 &, uint8 &, uint8 &)'
../../../include/nel/misc/entity_id.h:60: candidates are: NLMISC::CEntityId::CEntityId()
../../../include/nel/misc/entity_id.h:68:                 NLMISC::CEntityId::CEntityId(unsigned char, long long unsigned int, unsigned char, unsigned char)
../../../include/nel/misc/entity_id.h:76:                 NLMISC::CEntityId::CEntityId(unsigned char, long long unsigned int)
../../../include/nel/misc/entity_id.h:84:
NLMISC::CEntityId::CEnt

Best regards,
d.
-- 
 [email-masked]