Subject: [Nel] Linux compilation pb

From: Vincent Caron <[email-masked]>
Date: Wed, 07 Feb 2001 20:28:32 +0100

I couldn't compile src/3d/driver/opengl/driver_opengl_texture.cpp, it was
lacking the prototype for a GL extension function. I found out that "gl.h"
includes "glext.h". And "glx.h" include "gl.h". And so on ... The conclusion
is that you must define GL_GLEXT_PROTOTYPES (if needed) before *any* GL
inclusion. I took this block from driver_opengl_extension.h :

#ifdef NL_OS_UNIX
#define	GL_GLEXT_PROTOTYPES
#endif

and moved it to the very beginning of driver_opengl.h (before the #include
<GL/glx.h>).

---

From: "Vianney Lecroart" <[email-masked]>
Date: Thu, 8 Feb 2001 10:39:43 +0100

Thank you a lot for this bug correction.
It's really strange because it compiles well on our linux system without any
modifications,
but I already heard about this problem, I'll correct it right now.

Vianney Lecroart
---
lead programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geek.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

----- Original Message -----
From: "Vincent Caron" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 07, 2001 8:28 PM
Subject: [Nel] Linux compilation pb

> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel

---

From: Thierry Mallard <[email-masked]>
Date: Mon, 12 Feb 2001 15:28:32 +0100

> but I already heard about this problem, I'll correct it right now.

Just a quick word to say that the problem just appeared here. The proposed
correction seems to work.

Larger report when compilation ends.. :-)

	Shaman

-- 
Thierry Mallard              |              
GnuPG key on wwwkeys.pgp.net |
key 0xA3D021CB               |
http://thierry.mallard.com   |