Subject: [Nel] Linux: snowballs (almost) running

From: Vincent Caron <[email-masked]>
Date: Thu, 08 Nov 2001 19:46:26 +0100

I solved the GL driver loader pb : it was not linked against libGL. Attached the
one-liner patch to nel/src/3d/driver/opengl/Makefile.am to fix this.

I now have the splash screen, and then a nice segfault :). My client.cfg points
to a fresh data tarball (the URL was on this ML a few days ago). So I'll guess
I'll have to investigate again. I didn't compile in debug mode (too long, not
enough disk space for this task), so the trace is vague :

Starting program: /home/zerodeux/src/nevrax/code/snowballs2/client/src/snowballs 
[New Thread 1024 (LWP 27970)]
INF27970 client.cpp 145 : Starting Snowballs 1
[New Thread 2049 (LWP 27971)]
[New Thread 1026 (LWP 27972)]
[New Thread 2051 (LWP 27973)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 27970)]
0x40a8ced6 in _STL::_Rb_global<bool>::_M_increment () from
/home/zerodeux/src/nevrax/STLport/lib/libstlport_gcc.so
(gdb) bt
#0  0x40a8ced6 in _STL::_Rb_global<bool>::_M_increment () from
/home/zerodeux/src/nevrax/STLport/lib/libstlport_gcc.so
#1  0x405d64ec in NL3D::CScene::createInstance () from /usr/local/lib/libnel3d.so.0
#2  0x405d9e24 in NL3D::CInstanceGroup::addToScene () from /usr/local/lib/libnel3d.so.0
#3  0x4051272b in NL3D::CInstanceGroupUser::addToScene () from /usr/local/lib/libnel3d.so.0
#4  0x405133f5 in NL3D::CInstanceGroupUser::addToScene () from /usr/local/lib/libnel3d.so.0
#5  0x080678d7 in initLandscape ()
#6  0x08052ea0 in main ()
#7  0x40bab65f in __libc_start_main () from /lib/libc.so.6

---

From: Vincent Caron <[email-masked]>
Date: Thu, 08 Nov 2001 20:02:08 +0100

OK, I forgot the patch, sorry ! :))

Index: nel/src/3d/driver/opengl/Makefile.am
===================================================================
RCS file: /home/cvsroot/code/nel/src/3d/driver/opengl/Makefile.am,v
retrieving revision 1.7
diff -c -r1.7 Makefile.am
*** nel/src/3d/driver/opengl/Makefile.am	29 Oct 2001 10:51:00 -0000	1.7
--- nel/src/3d/driver/opengl/Makefile.am	8 Nov 2001 18:45:39 -0000
***************
*** 23,28 ****
--- 23,29 ----
  
  AM_CXXFLAGS                  = -I$(top_srcdir)/src
  
+ libnel_drv_opengl_la_LIBADD  = -lGL
  
  # End of Makefile.am

---

From: Cedric Valignat <[email-masked]>
Date: Mon, 12 Nov 2001 15:06:34 +0100

Hello Vincent,

I just commit the changes,

Thanks for your help and there is no problem for the fact that your
forgot the patch ;-)

Vincent Caron wrote:
> [...]

Cedric.