Subject: [Nel] Exec pb with '-with-debug'

From: Alain Dutech <[email-masked]>
Date: Tue, 26 Feb 2002 11:23:23 +0100

Hi,

trying too fixe some latent assert
- constant flow of :
AST12088 debug.h 384 : "dynamic_cast<T>(o)"

I compiled nel and snowballs2 with --with-debug
and then
[dutech@crevic client]$ snowballs
INF32265 client.cpp 145 : Starting Snowballs !
WRN32265 dru.cpp 95 : when loading dynamic library 'libnel_drv_opengl.so': /usr/local/lib/libnel_drv_opengl.so:
undefined symbol: setupUserTextureMatrix__Q24NL3D9CDriverGLUiRQ24NL3D9CMaterial
WRN32265 common.cpp 401 : Exception will be launched: libnel_drv_opengl.so not found
Abandon

Any hints? I thought Exception were to be catch somewhere...

My Config :
Red Hat 7.1 GNU/Linux
gcc version 2.96
STLport version 4.5.1
GL_VERSION: 1.2 Mesa 3.4
GL_RENDERER: Mesa DRI Voodoo3 20001101

CVS tree of 21/01/2002

Alain

---

From: Loic Dachary <[email-masked]>
Date: Tue, 26 Feb 2002 13:25:30 +0100

> Any hints? I thought Exception were to be catch somewhere...

	setupUserTextureMatrix was previously declared inline in
driver_opengl.h and that triggered this problem. It was fixed, though. Are
you using the CVS tree ? If not you should ;-)

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt