Subject: [Nel] Compilation under VC6

From: "Slistak Shady" <[email-masked]>
Date: Fri, 09 Feb 2001 21:47:18 -0000

Hi-

This is my first time at tryng to compile everything. Current problem I have 
is the following error when compiling NeL.

C:\NEVRAX\CODE\NEL\INCLUDE\nel/misc/types_nl.h(75) : fatal error C1189: 
#error :  "You need STLPort to compile this project (www.sltport.org)"
file.cpp

I'm sure it's just some config problem in my VC. I've downloaded and 
compiled sltport and freetype, and told VC where to find the include and lib 
file as per the INSTALL doc.

Any suggestions?

Thanks.
Brett
_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

---

From: Nicolas Hognon <[email-masked]>
Date: Fri, 09 Feb 2001 23:03:30 +0100

put the include directory of stlport before
in include from microsoft

Slistak Shady wrote:

> Hi-
> 
> This is my first time at tryng to compile everything. Current problem I 
> have is the following error when compiling NeL.
> 
> compiled sltport and freetype, and told VC where to find the include and 
> lib file as per the INSTALL doc.
> 
> Any suggestions?
> 
> Thanks.
> Brett

-- 
Nicolas Hognon
home : [email-masked]         / www.cblt.org
work : [email-masked] / www.virtools.com
#ICQ : 36044443

Enjoy the silence
(DM)

---

From: Róbert Bjarnason <[email-masked]>
Date: Fri, 9 Feb 2001 13:57:40 -0800

Hi Slistak,

Friday, February 09, 2001, 1:47:18 PM, you wrote:
SS> C:\NEVRAX\CODE\NEL\INCLUDE\nel/misc/types_nl.h(75) : fatal error C1189: 
SS> #error :  "You need STLPort to compile this project (www.sltport.org)"
SS> file.cpp

SS> I'm sure it's just some config problem in my VC. I've downloaded and
SS> compiled sltport and freetype, and told VC where to find the include and lib 
SS> file as per the INSTALL doc.

SS> Any suggestions?

In VC, try going into the Tools->Options menu and move
the reference to the stlport include files up using
the up arrow.  This is for the compiler to find
stlport before the standard MS libraries.

Warm regards,
Róbert