Subject: [Nel] Sound and OpenAL

From: "Dee" <[email-masked]>
Date: Thu, 8 Nov 2001 23:06:50 +1100

Hi

I have got the server and client running with no problem.  But when I play snowball, there is no sound...

I compiled the client on VC6, and I got the following error when compile the open_al:

===============================================================================
Compiling... 
buffer_al.cpp 
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : fatal error C1004: unexpected end of file found 
listener_al.cpp 
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : fatal error C1004: unexpected end of file found 
sound_driver_al.cpp 
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : fatal error C1004: unexpected end of file found 
source_al.cpp 
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) : fatal error C1004: unexpected end of file found 
Error executing cl.exe. 
nel_drv_openal_win.dll - 8 error(s), 0 warning(s) 
===============================================================================
I ignore this error and just go ahead with my client.  Is that why my client does not have any sound?
Thanks.

Wilson

---

From: Olivier Cado <[email-masked]>
Date: Thu, 08 Nov 2001 12:39:11 +0100

Hello,

> Dee wrote:

Currently, there is no sound in Snowballs.
 
> C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) :
> error C2146: syntax error : missing ';' before identifier 'EAXSetProp'
> C:\snowball\code\nel\src\sound\driver\openal\sound_driver_al.h(60) :
> fatal error C1004: unexpected end of file found
(...)

The sound engine is currently not necessary to run Snowballs.

But if you want to compile it for your own project (or to test
the 'sound_sources' sample), you need to install OpenAL and EAX
(get OpenAl from http://www.openal.org and EAX from
http://developer.creative.com/GAMES/DC_D&H_Games-Home.asp)
and to configure the following settings (the examples are given
for my configuration):

Include paths needed:
- OpenAL base platform dir (C:\NETSHARE\OPENAL\WIN)
- OpenAL include dir (C:\NETSHARE\OPENAL\WIN\AL)
- EAX include dir (C:\NETSHARE\CREATIVE LABS\EAX 2.0 EXTENSIONS SDK\INCLUDE)
- NeL src dir (R:\CODE\NEL\SRC)

Library paths needed:
- OpenAL .lib location (C:\Netshare\openal\win\openal32\release)
- OpenAL UT .lib location (C:\Netshare\openal\win\alut\release)
- EAX .lib location (C:\NETSHARE\CREATIVE LABS\EAX 2.0 EXTENSIONS SDK\LIBS)

At runtime, the user needs openal32.dll and eax.dll
(usually in the system directory).

You will find more info in the document at
/docs/doxygen/nel/nel_sound.html
as soon as this document is back online.

Note: EAX is currently supported under Windows only, but
the sound engine works under Linux (with no support of
environmental effects) yet.

Regards,
Olivier Cado
-- 
Olivier Cado
      Nevrax   
         NeL