Subject: [Nel] Building a FAQ?

From: "Jared Mark" <[email-masked]>
Date: Mon, 19 Feb 2001 15:56:00 -0600

What better way to build a FAQ than to have questions that are actually "frequently asked", right?

Well, as everyone has probably guessed by now, I'm not exactly an above-average programmer... so I'm going to ask some very basic questions that will probably get asked quite a bit by others of my limited experience and expertise.

1) Now that I have NeL, the Client, and Services packages all compiled, what do I do with it to actually start building MY world?  Do I HAVE to edit the code and recompile?  Or is this package meant to handle all game-specific stuff in that /data directory, independant from the core components?

2) What are the limitations on world size, max number of connections, etc, etc?  I understand there are obvious hardware restrictions that you can't really say anything about... but I'm talking about software restrictions (for example, will I run into problems with say, a bank account in my game going over 64k in size due to an overflow?  Will I have issues with my map being too big for the services to handle in terms of latteral area?)

That's it for now... 

Jared Mark (aka EagleEye)
--- Please don't hate me because I'm an idiot with this stuff still. :)

---

From: Vincent Archer <[email-masked]>
Date: Tue, 20 Feb 2001 18:00:00 +0100

According to Jared Mark:
> 1) Now that I have NeL, the Client, and Services packages all compiled,
> what do I do with it to actually start building MY world?  Do I HAVE
> to edit the code and recompile?  Or is this package meant to handle
> all game-specific stuff in that /data directory, independant from the
> core components?

Well, what you now have is a very small client, so don't expect to run a
RPG using that :)

But essentially, yes. You now have to fire off your favorite 3D modeller
and start making your own world (then, later get or write a converter to
generate our map format), or, if you find the current world fine... start
working on additional code to implement your features.

> 2) What are the limitations on world size, max number of connections, etc, etc?  I understand there are obvious hardware restrictions that you can't really say anything about... but I'm talking abo…

Basically? None. We haven't put any specific restriction. Bank accounts
aren't implemented yet, so they don't overflow :)

There are additional design decisions about the game I can't get into,
but, regarding map size for example, we do not have any restriction.
Apart from our capacity to produce them and the limitations on the
support for distribution (if we have to install 10Gb on your HD, it's
probably too much).

As a comparison, the artic icefield distributed with Snowballs covers
2.5km by 1.3, and we do expect to have a pair of PCs handle every services
regarding such a game area and about 50-100 active players.

(of course, that depends a LOT on how those services are sollicited, which
 ties directly into game play)

-- 
Vincent Archer                                         Email: [email-masked]

Nevrax France.                              Off on the yellow brick road we go!