Subject: [Nel] mesa3D

From: François Périchon <[email-masked]>
Date: Thu, 11 Jan 2001 16:13:25 +0100

It seems i need recent mesa3d libs to build NeL.
What version do i need?
Could you write the software versions needed to build in the INSTALL files.

-- 
François "Le Barjack"  Périchon
[email-masked]
[email-masked]
36, rue de la clef
59800 Lille
France
Tel : +33 (0)3 20 55 55 90 
Fax : +33 (0)3 20 55 55 92

---

From: Valignat Cedric <[email-masked]>
Date: Thu, 11 Jan 2001 17:18:40 +0100

Hello Francois,

> It seems i need recent mesa3d libs to build NeL.

We are using Mesa 3.3 and we didn't test NeL with other versions yet.

Could you tell us which version of Mesa you used, that could help us
to have a better idea about the NeL compatibility ...

> Could you write the software versions needed to build in the INSTALL files.

I updated the INSTALL file on that way ... it should be available on tonigth
on the public CVS.

Thanks,

Cedric.

---

From: François Périchon <[email-masked]>
Date: Mon, 15 Jan 2001 12:42:46 +0100

I used the mesa 3.2 which comes with the unstable debian.
On Thu, 11 Jan 2001 17:18:40 Valignat Cedric wrote:
> _______________________________________________
> Nel mailing list
> [email-masked]
> /mailman/listinfo.cgi/nel
> 
>

---

From: [email-masked] (Debian User)
Date: Wed, 17 Jan 2001 01:52:06 +0100

Hi,
I reported my disappointment in a previous post when I saw that up to date
 unstable Debian seemed not current enough for NeL.
I decided to get the latest release from www.mesa3d.org.
It was 3.4 but include/GL/glext.h seemed not current enough according to
the test of GL_GLEXT_VERSION  :-(( (I have 6, requested is 7)
So I decided to browse the CVS (http://cvs.sourceforge.net/cgi-bin/cvsweb.cgi/Mesa/include/GL/glext.h?rev=1.31&content-type=text/x-cvsweb-markup&cvsroot=mesa3d ) and here is what I found:

Revision 1.31, Sat Jan 6 22:46:13 2001 UTC (10 days, 1 hour ago) by
   gareth
  Branch: MAIN
  CVS Tags: HEAD
  Changes since 1.30: +9 -4 lines
Implementation of GL_EXT_texture_env_dot3.
...
  /* Header file version number, required by OpenGL ABI for Linux */
#define GL_GLEXT_VERSION 6
 
???
You guys are not up to date! you are ahead of time :-)

Btw, I tried to fake a correct GL_GLEXT_VERSION but compile fails later
:-(((

I hope to be able to compile NeL again soon ...

Bernard

---

From: "Vianney Lecroart" <[email-masked]>
Date: Wed, 17 Jan 2001 10:01:06 +0100

Hello,

> I hope to be able to compile NeL again soon ...

In fact, it's Mesa that is not synchronized with the official sgi
extensions.
You have to get the last glext.h from sgi:

http://oss.sgi.com/projects/ogl-sample/ABI/glext.h

and it will be ok (we ll add this to the INSTALL file)

Vianney Lecroart
---
lead programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geek.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?

---

From: Valignat Cedric <[email-masked]>
Date: Tue, 23 Jan 2001 11:39:33 +0100

> You guys are not up to date! you are ahead of time :-)

hehe, i checked the RedHat's rpm of Mesa and it include the last version
glext.h (version 7) from SGI and not from Mesa (version 6) ... :-)

I'm going to update the INSTALL file to put a note about it ...

Cedric.

PS: Sorry if it take a long time to answer your mail, i was in vavcation ...