Subject: [Nel] Documentation on Event/Character Scripting

From: "Mark Ewert" <[email-masked]>
Date: Sat, 10 Feb 2001 18:37:57 -0500

It took me awhile to finally compile 0.2 of nevrax.org for windows, but after numerous patches (some of them blatant kludges) I was able to compile both the client and server.

I thought an interesting first step to working with nevrax would be to add events/characters in the current environment. I have briefly skimmed the AI/scripting environment and I did not find any documentation on how to introduce events ? Any advice besides just reading through all the code ?

A side note, I found the documentation overall to be quite sparse. I'm sure this is something that will change as the project matures, but for new users/developers especially better documentation would be much appreciated. Of course, the lack of documentation could be a test ;)

Mark.

---

From: "sameh chafik Pro" <[email-masked]>
Date: Mon, 12 Feb 2001 09:13:39 +0100

Hello Mark and thank you,

>I thought an interesting first step to working with nevrax would be to add events/characters in the current environment. I have briefly skimmed the >AI/scripting environment and I did not find any documentation on how to introduce events ? Any advice besides just reading through all the code ?

Yes we know and we are very sorry. At present we work on the client/server modele for data distribution modele because events in AI script work on local model. When we finish this work we'll write a doc. It do'nt take long time do do this job.