Subject: [Nel] NeL M4 macros bug

From: Cedric Valignat <[email-masked]>
Date: Mon, 28 Jan 2002 19:10:46 +0100

Hi all,

I found a big bug in NeL's M4 macros and that break the configure
scripts of NeLNS and Snowballs so i have to rewrite a part of it :-(

I will send a mail to the mailling list when it will be fixed (tomorrow).

Sorry about that ...

Cedric.

---

From: Cedric Valignat <[email-masked]>
Date: Tue, 29 Jan 2002 14:35:51 +0100

Hi all,

It's fixed and i just synchronized the public CVS so it's avalaible ...

Cedric.

---

From: David MENTRE <[email-masked]>
Date: 30 Jan 2002 21:52:53 +0100

> It's fixed and i just synchronized the public CVS so it's avalaible ...

Success report: the configure script runs flawlessly. It detects xml-2,
OpenAL and STLport without any problem. My machine is a Debian 3.0
(woody/testing).

Great work Cedric ! Many thanks.

Best regards,
david

Command line used:
david@oops:~/pub/NeL/code/nel$ ./configure --with-stlport=/usr/local/Installed/STLport4.5/ --enable-sound --enable-ai --with-openal=/usr/local/Installed/OpenAL-1.0/ --prefix=/usr/local/Installed/NeL

Relevant excerpt of the ./configure:

checking for STLPort headers... /usr/local/Installed/STLport4.5//include/stlport
checking for STLPort libraries... /usr/local/Installed/STLport4.5//lib
checking for OpenAL headers... /usr/local/Installed/OpenAL-1.0//include
checking for OpenAL libraries... /usr/local/Installed/OpenAL-1.0//lib
checking for python... no
checking for python2.1... no
checking for python2.0... no
checking for python1.5... /usr/bin/python1.5
checking for Python headers... /usr/include/python1.5
checking for Python libraries... /usr/lib/python1.5/config
checking for xml2-config... /usr/bin/xml2-config
checking for libxml - version >= 2.0.0... yes (version 2.4.12)
checking for freetype-config... /usr/bin/freetype-config
checking for FreeType version = 2... yes
checking for FreeType libraries... yes
checking for OpenGL headers and GL Version >= 1.2... yes
checking for <GL/glext.h> and GLEXT version >= 7... yes
checking for OpenGL libraries... yes
checking for XF86VidMode extension... yes

-- 
 [email-masked]