Subject: [Nel] 3ds4

From: "Valerio Santinelli" <[email-masked]>
Date: Sat, 6 Oct 2001 12:20:07 +0200

There's something wrong with nel_mesh_lib.. it goes in conflict with the MS Platform SDK or the Standard ATL (depends if you've istalled the latest MS PSDK or not, but the problem is the same).

--------------------Configuration: nel_mesh_lib - Win32 Release--------------------
Compiling...
stdafx.cpp
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(623) : error C2146: syntax error : missing ';' before identifier 'Address'
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(623) : error C2501: 'ADDRESS' : missing storage-class or type specifiers
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(623) : error C2501: 'Address' : missing storage-class or type specifiers
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(624) : error C2065: 'MAX_NAME_SIZE' : undeclared identifier
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(624) : error C2057: expected constant expression
C:\Programmi\Microsoft Platform SDK\include\bhtypes.h(625) : error C2229: struct '_ADDRESSINFO' has an illegal zero-sized array
C:\Programmi\Microsoft Visual Studio\MyProjects\nevrax\code\nel\tools\3d\plugin_max\nel_mesh_lib\stdafx.h(44) : fatal error C1083: Cannot open include file: 'bipexp.h': No such file or directory
Error executing cl.exe.

nel_mesh_lib.lib - 7 error(s), 0 warning(s)

Here's a piece of bhtypes.h

//=============================================================================
//  AddressInfo structure
//=============================================================================
#define SORT_BYADDRESS  0
#define SORT_BYNAME     1

#define PERMANENT_NAME  0x00000100

typedef struct _ADDRESSINFO *LPADDRESSINFO;
typedef struct _ADDRESSINFO
{
    ADDRESS        Address;
    WCHAR          Name[MAX_NAME_SIZE];
    DWORD          Flags;
    LPVOID         lpAddressInstData;
} ADDRESSINFO;

#define ADDRESSINFO_SIZE    sizeof(ADDRESSINFO)

I guess ADDRESS or whatever gets overridden by something in NeL, but I have no clue..

--
c'ya!

Valerio Santinelli
[email-masked]
HateSeed Gaming Magazine http://www.hateseed.com/
My Lab http://tanis.hateseed.com/
In Flames Italia http://www.inflames.it/

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Mon, 8 Oct 2001 19:20:59 +0200

I really don't know what is the problem.
Have you tried to change the include directory order in your Tools/Options/Directory menu ?
The mine is:

STLPort,
MaxSDK,
NeL/src,
NeL/include,
Directx,
Visual,
Freetype,
Openal,
Libxml

Cyril.
   
  --------------------Configuration: nel_mesh_lib - Win32 Release--------------------
  Compiling...
  stdafx.cpp