Subject: [Nel] NeL 3D Library : Features

From: Loic Dachary <[email-masked]>
Date: Tue, 12 Feb 2002 10:57:57 +0100

Hi,

	I wonder if the /docs/features_nel_3d.php3
page is up to date. It does not contain a date, therefore I feel the need
of bothering people ;-)

	Here are a few typo fixes:

s/dissable/disable/
s/technicque/technique/
s/ofobjects/of objects/
s/insuffricient/insufficient/

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt

---

From: "Daniel Miller" <[email-masked]>
Date: Mon, 18 Feb 2002 11:12:09 +0100

This one is a little out of date - I wrote it last April.
The feature list hasn't realy changed, but the 'to be developed' and 'in
development' listings are badly out of date.

We'll give it a once over shortly.

Regards,
Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Loic Dachary
Sent: Tuesday, February 12, 2002 10:58 AM
To: [email-masked]
Subject: [Nel] NeL 3D Library : Features

	Hi,

s/dissable/disable/
s/technicque/technique/
s/ofobjects/of objects/

	Cheers,

--
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt
_______________________________________________
Nel mailing list
[email-masked]
/mailman/listinfo.cgi/nel

---

From: Loic Dachary <[email-masked]>
Date: Mon, 18 Feb 2002 19:28:08 +0100

> We'll give it a once over shortly.

	That would be nice. Here are a few features I found in other
3D engines. You may want to add them to the list, even if to say that
Nel does not support XXX this because it supports YYY that is
superior. It would help people understand why and how Nel is better
than any existing Free Software 3D engine.

	That would help a lot when comparing. You also want to
s/frustrum/frustum/ ;-)

----
     True perspective rendering
     True 6DOF engine
     Arbitrary sloped convex polygons

     Flexible plugin system which allows for plugging in other
     Generic mechanism that allows plug-and-play capabilities and

     Support for 8-bit (palette), 15/16-bit (truecolor), and 32-bit (truecolor) displays.
     Run at many resolutions (320x200, 640x480, 800x600, ...).
     Window or fullscreen mode, up to 1024x768 (30fps on minimal config)

     Visibility system based on [portals, octrees, BSP trees,
	c-buffer, CSG].
     Hierarchical bounding box collision detection system.
     Elipsoid collision detection.
     Polygon level collision detection for terrain and 3D objects

     Font system plugin to support other font types

     Textures can have any size which is a [power of two / not a power
       of two] and they [need / need not] be square.
     Supports textures with various formats including GIF, TGA, PNG,
       BMP, JPG, and others.
     Perspective correct texture mapping with interpolation every xx pixel.
     Transparent and semi-transparent textures allowing for
       see-through water surfaces and windows.
     Support for dynamic textures (i.e. texture that you can render
       on and put on a polygon as well as normal textures).
     Support for internal 24-bit textures with a private colormap for
       every texture or true 24-bit.

     Multiple 3D windows and real-time cameras for 1st or 3rd person views
     Split screen
     Zoom

     Full programmable and customizable through scripting language

     Light maps
     Trilinear mip mapping
     Mip mapping
     Animated 3D sprites
     Animated 3D decals
     Heightmap based deformable terrain for landscapes
     Geometric LOD
     Smooth mesh deformation for models
     Flat and cubic environment map rendering
     Mirrors and alpha mapping you can create really nice shiny or
        reflecting surfaces.
     Procedural textures for water or lava.
     Programmable 2D and 3D effects (lens flares, bullet holes etc.)
     Camera portals and mirrors
     Programmable particle and beam generators
     Particle system using 2D sprites

     Path tracking for camera, actors or vehicles
     Animated soft-skin models with unlimited skin size
     3D triangle mesh sprites with frame animation.
     Support for skeletal sprites.
     3D objects can be taken or manipulated with mouse in real time
     Moving objects 
     Script language controlling object movement.

     3D sound sources (DS3D, EAX, A3D, ...) with Doppler effect
     CD Audio, MID and WAV support for music and 3D sounds
     Sound formats: WAV, MP3, Ogg/Vorbis, AU, AIFF, IFF, and MOD (using MikMod).
     Save / Load feature for resuming games at arbitrary positions
     Convertors for Quake MDL and Quake II MD2 formats
     Convert MAP files (from Quake/HalfLife) from/to internal format. 
     Convert 3DS to models or levels.
     Load 3DS, MDL, MD2, ASE, OBJ, or POV objects.
     ASCII world file format allowing you to easily redefine the world.
     Store levels in standard compressed ZIP archives to make a bundle of one level.

     Animated multi-layered sky and backdrop bitmaps
     Multi-layered and animated skyboxes and skydomes.
     Dynamic gouraud shaded sky dome (half-sphere) 
     Moving sun which actually modifies the color of the sky in real time
     Halo's around lights.
     Coloured fog areas
     Depth-correct colored volumetric fog in sectors (software & hardware)
     Integrated 2D engine for background pictures

     Multi-player client/server mode via network (TCP or UDP)

     2D sprites, panels, buttons, sliders, overlays
     2D controls, text, screenshots, and movie scenes
     Static and dynamic coloured light sources
     Static colored lights with real shadows. Lighting and shadows
     Static and dynamic shadows
     Dynamic colored lights with soft shadows
     Precalculated Radiosity on the Lightmaps
     Arbitrary axis (quaternion) rotations 
     Remote or missile cameras
	
----

---

From: "Cyril 'Hulud' Corvazier" <[email-masked]>
Date: Mon, 25 Feb 2002 17:49:32 +0100

Hi Loïc,
Give me some days to give you a feedback on this :-)

-h