Subject: [Nel] Asserts (more information)

From: Loic Dachary <[email-masked]>
Date: Fri, 22 Feb 2002 12:33:57 +0100

The following asserts show when I hit the caps lock key:

AST 9065 bit_set.h 74 : "bitNumber>=0 && bitNumber<NumBits"
AST 9065 bit_set.h 86 : "bitNumber>=0 && bitNumber<NumBits"

	STL-4.5, Debian GNU/Linux, XFree-4.2, freetype2, gcc-2.95.4.

	Cheers,

-- 
Loic   Dachary         http://www.dachary.org/  [email-masked]
12 bd  Magenta         http://www.senga.org/      [email-masked]
75010    Paris         T: 33 1 42 45 07 97          [email-masked]
        GPG Public Key: http://www.dachary.org/loic/gpg.txt

---

From: Vincent Caron <[email-masked]>
Date: 22 Feb 2002 16:04:42 +0100

> AST 9065 bit_set.h 86 : "bitNumber>=0 && bitNumber<NumBits"

I'm experiencing the same ones. Vianney asked me to track them down but
I don't have a debug versions of the libs (I need to make some space on
my hard drives), and what's worse no free time these days ...

---

From: "Vianney Lecroart" <[email-masked]>
Date: Mon, 25 Feb 2002 10:50:11 +0100

> AST 9065 bit_set.h 86 : "bitNumber>=0 && bitNumber<NumBits"

Ok, the problem should come from event_listener in misc module that use a
bit set (the keyboard state) and caps lock keys value is perhaps out of
bound of this bit set.
event.h contains all the key (0 to 0xFF) so the bit set size is 0xFF and
Caps Lock is not in this enum so the value is perhaps random and make an
assert when trying to access to the bit set.

Vianney Lecroart
---
lead network programmer / nevrax.com
icq#: 6870415
homepage: http://ace.planet-d.net
www.geekcode.com: GCS/E d- s+++: a-- C+++$ UL++ P- L+++>+$ E+>- W++ N+ o? K-
w++$ O- M- V- PS- PE? Y PGP t 5? X+ R- tv++ b- DI D+ G e++ h+ r-- y?