Subject: [Nel] Release Schedule and some questions ?

From: "Tom wright" <[email-masked]>
Date: Sun, 19 Nov 2000 14:14:11 -0000

Hi all,

I am quite interested in what your trying to do, having played about with the ideas for one of these for more years than I care to think about :-)

I have some general questions I would like to ask who ever is in the know, feel free to ignore the 'sensitive' ones :-)

1)  Are you going to add to the FAQ how to build  the stuff ? I am currently running on Win2k with VC6 ( though I have a linux box also to try this out on ) and it appears you have some paths coded to your environment and not within the project file, e.g. whatever\nel\include is missing.
It would be useful in the FAQ if it contained a list of any dependencies that the system also requires like the STL code. Yeah I know its in there :-)  But it will save you answering the same question lots of time for those that don't look at the src

2) Care to release at least a rough schedule on the website, so that people can see when bits and pieces of the jigsaw are going to be released ?

3) Congrats on releasing the src early, that means we can start reading and learning now before we have 1000's of files to wade through.

4) very interested to see talking about using python, having started playing with it a few months ago, it has alot going for it.  Are you going to embed it and interface it to the API's available so that people can use it for developement within the system, or is it more an external glue language ? Could be very useful for rapid prototyping AI and NPC routines

5) In your event dispatch system, how do you intent to get around the problem of 'event blizzards' on a busy system ? Having seen this problem in other systems that rely on events for inter-object comms, I am interested on how you are going to get around the problem, e.g. multi-threaded round robin dispatch, multiple dispatchers etc.

Congrats on embrassing the open source idea for your server, and I look forward to messing around with the system and the source.

Regards

Tom

---

From: "sameh chafik Pro" <[email-masked]>
Date: Mon, 20 Nov 2000 09:59:53 +0100

> 4) very interested to see talking about using python, having started playing with it a few months ago, it has alot 
> going for it.  Are you going to embed it and interface it to the API's available so that people can use it for 
> developement within the system, or is it more an external glue language ? Could be very useful for rapid prototyping > AI and NPC routines

Hello, 
I'am Sameh Chafik and i am the lead AI programmer, I work with Pierre Portier and Gabriel Robert. At present we don't use Python, i begun to embed all class that we write but because we design a multi agents system, we decideded to write an script interpret for our agents platform. That dicision become because in open-source platform we did'nt find an embed language for prototyping agents and python is'nt adapt for doing that.

---

From: "Vianney Lecroart" <[email-masked]>
Date: Mon, 20 Nov 2000 10:12:40 +0100

>1)  Are you going to add to the FAQ how to build  the stuff ? I am
currently running on Win2k with VC6 ( though I have a linux box also to try
this out >on ) and it appears you have some paths coded to your environment
and not within the project file, e.g. whatever\nel\include is missing.
>It would be useful in the FAQ if it contained a list of any dependencies
that the system also requires like the STL code. Yeah I know its in there
:-)  But it >will save you answering the same question lots of time for
those that don't look at the src

I'm working on the Visual C++ INSTALL file that explains everything you have
to do to install and compile our project. It should be available in few
days. (The unix one should come too in few days). But we don't plan to add
it in the faq, we'll put it in the root directory.

>3) Congrats on releasing the src early, that means we can start reading and
learning now before we have 1000's of files to wade through.

Thanks

-Vianney Lecroart

---

From: Dim Segebart <[email-masked]>
Date: Wed, 22 Nov 2000 17:12:32 +0100

Hello !
Today I have found very interesting library from SGI
(http://oss.sgi.com/projects/state-threads/)
It's based on Netscape Portable Runtime library (NSPR)
and amed on creating high perfomance network applications.
Look at documentation
(http://oss.sgi.com/projects/state-threads/docs/st.html)
From documentation:

It is contained in 8 source files as opposed to more than 400, but
provides all the
functionality that is needed to write efficient IAs on UNIX-like
platforms.

                     NSPR       State Threads
 Lines of code     ~150,000      ~3000

 Dynamic library size
(debug version)
 IRIX               ~700 KB   ~60 KB
 Linux             ~900 KB  ~70 KB

State Threads is an application library which provides a foundation for
writing Internet Applications. To summarize, it has the following
advantages:

     It allows the design of fast and highly scalable applications. An
application will scale well with both load and number of CPUs.
     It greatly simplifies application programming and debugging
because, as a rule, no mutual exclusion locking is necessary and the
entire application is free to use static variables and non-reentrant
library functions.

The library's main limitation:
     All I/O operations on sockets must use the State Thread library's
I/O functions because only those functions perform thread scheduling and
prevent the application's
     processes from blocking.

I'm just wonder, what is the implimenantion design of NeL server-side
according to the above document ?

---

From: Olivier Cado <[email-masked]>
Date: Thu, 23 Nov 2000 10:54:34 +0100

Hello everybody !

> according to the above document ?

During the pre-production we studied various libraries, from the
smallest to the biggest (such as ACE,
http://www.cs.wustl.edu/~schmidt/ACE.html ). We didn't find the one of
our dreams :-)

At the moment we have implemented a simple networking system to work
with our prototype that is coming soon.

Thank you for your suggestion. We will study this library in detail.

Regards,
Olivier
-- 
Olivier Cado    ICQ: 67756413
NEVRAX France    -